HassIO supervisor won't start after Containerd upgrade. System broken

I run Debian 10.8 as host system and today I did apt-get upgrade and got containerd.io upgrade from 1.4.3-1 to 1.4.4-1). After the upgrade all my docker containers where stopped. So I rebooted the system and after that most of the containers where started and running correctly. Except all HomeAssisant en HassIO containers.

When I tried to start the HassIO supervisor manually it will stop after a few seconds. There’s no exception or something in the log:

21-03-12 17:26:18 INFO (MainThread) [__main__] Initializing Supervisor setup

21-03-12 17:26:18 INFO (MainThread) [supervisor.bootstrap] Initializing Supervisor Sentry

21-03-12 17:26:18 INFO (MainThread) [supervisor.bootstrap] Seting up coresys for machine: qemux86-64

21-03-12 17:26:18 INFO (SyncWorker_0) [supervisor.docker.supervisor] Attaching to Supervisor homeassistant/amd64-hassio-supervisor with version 2021.03.4

21-03-12 17:26:18 INFO (MainThread) [supervisor.homeassistant.api] Updated Home Assistant API token

21-03-12 17:26:18 INFO (MainThread) [supervisor.resolution.evaluate] Starting system evaluation with state CoreState.INITIALIZE

21-03-12 17:26:18 INFO (MainThread) [supervisor.resolution.evaluate] System evaluation complete

21-03-12 17:26:18 INFO (MainThread) [__main__] Setting up Supervisor

21-03-12 17:26:18 INFO (MainThread) [supervisor.api] Starting API on

21-03-12 17:26:18 INFO (MainThread) [supervisor.hardware.monitor] Started Supervisor hardware monitor

[cont-finish.d] executing container finish scripts...

[cont-finish.d] done.

[s6-finish] waiting for services.

[s6-finish] sending all processes the TERM signal.

[s6-finish] sending all processes the KILL signal and exiting.

I tried several things to start of fix the supervisor but with no succes. For example:

banaan@serverbanaan:/usr/share/hassio$ sudo ha supervisor reload
Error response from daemon: Container 12efbd04d805e11e0e80c1db1ed555299ef3529f132675ca1964c5db36d6cffd is not running

Anyone any suggestion how to get my system back online? I read several posts online that restoring a snapshot wont’t fix the problem, because the problem is at the host of the system.

I did’t such huge impact of containerd upgrade. I’ve checked my apt-get upgrade command and containerd was the only installed / upgraded package. And I checked sky logfiles from different containers and they stopped working around the time I upgraded containerd.

My host is running Docker version 20.10.5, build 55c4c88

Glad I didn’t make that upgrade when I saw it.
Try reverting the containerd version

I tried to revert to the old version.

banaan@serverbanaan:/usr/share/hassio$ sudo apt-get install containerd.io=1.4.3-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libasound2 libasound2-data libbrlapi0.6
Use 'sudo apt autoremove' to remove them.
The following packages will be DOWNGRADED:
0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 0 B/28.1 MB of archives.
After this operation, 914 kB disk space will be freed.
Do you want to continue? [Y/n] y 
dpkg: warning: downgrading containerd.io from 1.4.4-1 to 1.4.3-1
(Reading database ... 45915 files and directories currently installed.)
Preparing to unpack .../containerd.io_1.4.3-1_amd64.deb ...
Unpacking containerd.io (1.4.3-1) over (1.4.4-1) ...
Setting up containerd.io (1.4.3-1) ...
Processing triggers for man-db (2.8.5-2) ...

But unfortunately that did not help. HassIO supervisor still won’t start. Hassio_observer is the only running HassIO/HA container.

Does anyone know where to look to get a more detail error of logfile for that HassIo supervisor?

Can you start supervisor manually?

You mean on a different way then starting the supervisor container?

I wasn’t sure if you’d tried restarting it after the downgrade.
If so try a reboot that quite often solves a docker issue for me

I fixed the problem by running the HassIO install script again

curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s

Now I will try upgrading containerd and when it’s broken again I will try running the install script again.

The docker Devs have been putting out some shoddy updates lately.
Are you on a pi?
Looks like a bug has been reported effecting arm machines

Nope I am using a Intel NUC with Debian 10.8 installed.