Hassio time zone setting

how to setup the time setting in home assistant with hassio ?
my time is showing ok in HA overview but when i check the hassio logs there the time zone is not correct , it is working as per GMT , but i want to to be GMT +5.30 ,
how to do that ?

Home Assistant notifications (Log started: 2019-05-09T18:30:00.037242+00:00)

2019-05-09T18:30:00.037356+00:00 2713,1661,1347.254
2019-05-09T19:30:00.020414+00:00 2757,1632,1349.736
2019-05-09T20:30:00.023052+00:00 2779,1584,1351.477
2019-05-09T21:30:00.026749+00:00 2787,1542,1353.348

I believe the logs stay in GMT. HA only displays local time on the front end.

How to change the time of the log according to our location ?

Is it possible ?

Entries in the home-assistant.log should actually be timestamped in local time.

What type of system are you running HA in?

Hassio, rasbian etc…

What is the output of this when pasted in the dev tools template editor:

{{ utcnow() }}
{{ now() }}
{{ utcnow().astimezone() }}
{{ now().astimezone() }}
{{ utcnow().tzinfo }}
{{ now().tzinfo }}
{{ now().astimezone().tzinfo }}

Sorry to hijack the ocnversation, but i’m having the same issue. In my case the following is the output from the template when i run it. My system is Hassio.

2019-05-19 15:22:09.020579+00:00
2019-05-19 10:22:09.020669-05:00
2019-05-19 10:22:09.020786-05:00
2019-05-19 10:22:09.022639-05:00

If CDT is your correct timezone then your system and Hassio container times are correct.

its a long time i didnt tried this time setting and this post ,

as per ur template the result is

2019-08-07 18:16:02.597057+00:00
2019-08-07 23:46:02.597143+05:30
2019-08-07 23:46:02.597258+05:30
2019-08-07 23:46:02.597627+05:30

but my home assistant notification log file always shows the result in UTC +0 only

Home Assistant notifications (Log started: 2019-05-09T18:30:00.037242+00:00)