HASSIO - Update Home Assistant image fails "No such image"

Tags: #<Tag:0x00007f325e51c948>

Hey everyone, not sure where to start troubleshooting this?

20-05-26 01:14:34 INFO (MainThread) [supervisor.homeassistant] Update Home Assistant to version 0.110.2
20-05-26 01:14:34 INFO (SyncWorker_0) [supervisor.docker.interface] Update image homeassistant/qemux86-64-homeassistant:0.110.1 to homeassistant/qemux86-64-homeassistant:0.110.2
20-05-26 01:14:34 INFO (SyncWorker_0) [supervisor.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.110.2.
20-05-26 01:15:29 ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install homeassistant/qemux86-64-homeassistant:0.110.2 -> 404 Client Error: Not Found ("no such image: homeassistant/qemux86-64-homeassistant:0.110.2: No such image: homeassistant/qemux86-64-homeassistant:0.110.2").
20-05-26 01:15:29 WARNING (MainThread) [supervisor.homeassistant] Update Home Assistant image fails

Trying to upgrade to 0.110.2 from 0.110.1

Typically an indication that there’s insufficient storage space for the new image.

1 Like

@123 You are spot on the money!

Delving deeper, it seems it is docker that is chewing up 18GB of storage, and it doesn’t seem easy to “unpick” which is annoying

I’m having a similar problem with the 0.115 versions. I’m currently running 0.114.3.
Here’s a log snippet:

20-10-02 11:04:33 INFO (SyncWorker_4) [supervisor.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.115.6.
20-10-02 11:05:17 ERROR (SyncWorker_4) [supervisor.docker.interface] Can’t install homeassistant/raspberrypi3-homeassistant:0.115.6 -> 404 Client Error: Not Found (“no such image: homeassistant/raspberrypi3-homeassistant:0.115.6: No such image: homeassistant/raspberrypi3-homeassistant:0.115.6”).
20-10-02 11:05:17 INFO (SyncWorker_4) [supervisor.docker.interface] This error is often caused by not having enough disk space available. Available space in /data is: 105.1 GiB
20-10-02 11:05:17 WARNING (MainThread) [supervisor.homeassistant.core] Update Home Assistant image failed

The error can’t be because of insufficient disk space, there’s just over 105 Gigabytes available!
I’ve rebooted the Raspberry Pi 3, I’ve tried ‘ha supervisor repair’ and ‘ha core rebuild’ but neither one allowed the update to proceed. Is there a more detailed log somewhere that would show the real problem?

Best way to see what is wrong : SSH into the host (not the HA container !) en issue the command :

docker pull homeassistant/raspberrypi3-homeassistant:0.115.6

I ran the “docker pull” command you’ve suggested. The error was:

Failed to register layer: error creating overlay mount to /mnt/data/docker/overlay2/####/merged : too many levels of symbolic links

I looked in the overlay2 directory. It has 84 directories in it, most named with a long hex string. Eight of them have an additional ‘-init’ on the end. One directory is simply named ‘l’ (lower-case ‘L’). That directory has 83 symbolic links.

Can I just delete some of the entries? How do I know which ones to delete? Just delete the oldest directories and corresponding entries in the ‘l’ directory?

Thanks for you help!

That is a difficult one. The last years, I have seen this error a few times, but google never provided a real answer.

I tried running “docker system prune --volumes -a” and rebooting but that didn’t change the behavior. I don’t use the Raspberry Pi for anything but Hassio. Until now I’ve only used the lovelace web interface, updating the supervisor or home assistant core when it said one was available. Seems strange that the built-in update process would fail in a way that locks out future updates.

I ended up installing the Samba plug-in, copying the backup folder, and re-imaging the SD card.
I then had to install the Samba pug-in and restore my latest snapshot. That brought me back to 0.114.3 and I was able to upgrade to 0.115.6.
I guess I upgraded too many times so docker couldn’t merge all the overlays.
Version 0.116.1 is out now, it looks like it could save me a step in the future. I shouldn’t have to install the Samba plug-in just to restore a snapshot.