Hassio via docker SSD

Anyone of you running a ras 3B+ SSD boot and hassio via docker?
I have a few quetions, trying to get to boot. Here is my setup, and what I have done so far.
Downloaded Raspbian Stretch Lite from the official page, extracted the .zip file so i had the 2018-11-13-raspbian-stretch-lite.img file. Then launched Etcher, located the IMG file, and flashed the SSD with it.
When finished flashing, disconnected the drive, put the ssd to usb cable on, and just to be sure I connect it via a usb hub with external power. Try to boot the ras, but nothing happens.
The disc is a Kingston 60 gb SSD disc, that runs perfectly in my testmaschine.
Any tips ?
Kind regards


i also tried (and failed) with a usb 3.0 to sata enclosure (inateck) + evo 750 500GB.
RPI 3b+

I used balenaEtcher to write the hassio image (hassos) to the ssd/enclosure.
Connected the ssd to raspberry usb, no microsd, powered on, did not boot.
Also tried to copy from the ssd to microsd (formatted FAT32) the file bootcode.bin.

tried 2 microsd cards:

  1. 4gb samsung (probably not class 10) was not liked by the raspberry pi, since the usb did not initialize (led on the ssd enclosure remained off)
  2. 16 gb kingston (class 10, tested before ok) appeared to work/advance that point, because the usb gets power and enclosure led blinks few times. Also the green led on the raspberry blinks few times (i assume network led).
    But from there, it remains stuck and i believe the raspberry pi fails to get proper network.

please try the options mentioned here:
I tried the option 1, even including the timeout file, but without success.

Will try again today, maybe i have a problem with the network/static ip allocation for that raspberry in my router.

Unfortunately, since the hassos does not display anything on the hdmi port, it’s very hard to troubleshoot what’s happening. Any option to enable the display?


more tests, more info:

  1. it turns out hassos does display something on hdmi. my fault, i plugged a wrong hdmi cable… after plugging the correct hdmi cable into the raspberry, got the attached output.
  2. this was test to confirm that hybrid booting from sd card + ssd is possible: i could successfully boot Raspbian from usb ssd using option 1 mentioned in my previous link (copy bootcode.ini to sd card, write the entire image to ssd). While this is reassuring, what i really want is hassos, not Raspbian!
  3. I re-wrote the hassos image to usb sata, and copied bootcode.ini from usb sata to sd card.
    but no luck booting hassos.
    i tried other combinations, like using the bootcode.ini from Raspbian to the sd card, and even placing this raspbian file into the fat32 partition of the usb sata while rest of files are from hassos. still no luck…

trying now hassbian

hassbian boots ok using option 1 (sd as FAT32 with only bootcode.ini + hasbian image written on usb ssd)

on the other hand, hassos does not like this method.
not sure what else should be tried.

HassOS won’t work on anything but an SD-Card. (On a Raspberry Pi that is)

Thanks David.

I searched few hours ago and found some threads with this conclusion.

Also, if i understand correctly, there are some works for allowing ssd boot for hassos in the future. If that’s the case, I’m hardly waiting.
I’m currently using influxdb and mariadb components located on different server and not on the raspberry hosting hassos, to reduce the sd card IO operations (& to reduce the risk of failing sd card).

From what I have seen, the only thing they intend to allow is for the database to be on some other storage. I haven’t seen any intention to allow booting from other media.

What you can do is install raspbian lite as a ssd boot and then install docker and do the generic linux hassio install on that. I did do this and it was great.

oh, i see…

Indeed, it seems this is the only path forward currently.
I was also considering the raspi lite + docker HA + the other dockers i need.
For sure will miss the easy life of ha addons…

do you use portainer? what’s your recommendation to manage the docker containers?


You can install hassio in docker - no need to not have your cake and eat it too. Remember it’s a pi so I would not add anything that isn’t a hassio addon but plenty of people do.

Is any chance to boot Hass.io from SSD ? Or only by docker ?

I have recently added an SSD to an old Raspi 3B which is running MariaDB and my live HA on a Raspi 3B+ connects to it over my home network.

Here is a guide that I wrote at the time of the install that may be useful to follow

1, Download Raspbian Stretch Lite from Raspberry Pi and flash to the SSD using Etcher


Connect the SSD via USB to any USB port on the Pi, connect Pi up to TV and turn on the power. Raspian should boot shortly and the Pi will resize the SSD. To connect to your network use an ethernet cable or connect to WiFi on the top right of Raspbian entering your home SSID/PW.

2, You will need to enable SSH on the Pi as well, guide here :-

Once SSH is enabled connect to the Pi using Putty username & password are pi and raspberry - good time to change the default password using “sudo passwd”

3, Install Docker - The easy way to set up Docker on a Raspberry Pi

curl -fsSL get.docker.com -o get-docker.sh && sh get-docker.sh

4, Install HA - GitHub - home-assistant/supervised-installer: Installer for a generic Linux system

sudo apt-get install jq // you may need to install jq first
sudo mkdir /usr/share/hassio // create container
sudo su // enable superuser
curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s – -m raspberrypi3

After a while Hassio should start the full install and be available in a browser via its IP address on port 8123.

I have recently added an SSD to an old Raspi 3B which is running MariaDB and my live HA on a Raspi 3B+ connects to it over my home network.

Reading this sound like you have two raspberry pi but reading the instructions seems like you did it on only 1 RPI3

I did install hass.io on a rpi3b+ which boots directly from a SSD following more or less the same steps in this post. No SD at all. It works great, I like it more hass.io running on top of Raspbian (buster) than on HassOS. Raspbian is a much more tested OS than HassOS

Connect the SSD via USB to any USB port on the Pi, connect Pi up to TV and turn on the power. Raspian should boot shortly and the Pi will resize the SSD.

This guide also help me as I was unable to boot from the SSD at the beginning and had to use the “program_usb_boot_mode=1” on the RPi 3 B+

1 Like

I do have 2 Pi’s running HA. My main HA is on the Pi 3b+ running off an SD card as it sits in the living room under the TV. The SSD pi is a 3b which is being used as a print server using CUPS and also as the MariaDB server where the main HA sends all its sensor data.

Hoping to update the main pi to a Pi4 in the next few months once they release an update to allow SSD booting which you cannot do at the moment.