HASSIO VirtualBox Samba interface name?


i’m looking for some help.
i had my install on a PI and moved it to VirtualBox.
Works great, except SAMBA.

The issue is that i cannot find the Interface name.
i did find this peace in the documentation
(string)(Optional)Interface that will start the share. Normally this is eth0 for ethernet wired connection and wlan0 for wireless connection. If you are running on an Intel NUC this could also be enp3s0 for ethernet or wlp5s0 for wireless connection.

tried them but HASSIO (Samba plugin) keeps telling me that it cannot find the interface.

Do i need to leave this empty or ?

im googeling this for 2 days no wins on that part.

i also tried via the CLI:
the documentation states you can find info there with the “network info” but this is ripped out of the available commands.

is there something i’m missing ?

I use the virtualbox generated console.

ip addr|grep 192.168

This tells me it is enp0s17

However I just left it blank, ie

"interface": "",

ty, i tried it again and it worked after saving and then restarting samba.

I fortunately added the add-on Glances and found my interface name there. mine was enp0s3
plugged it in and it resolved the no interface issue.
Now off to resolving another issue with the domain name being too long.
Tried WORKGROUP only my internal network doesn’t see the hassio virtualbox identity.

Just use windows explorer and put the ip address after two backslashes, ie


Thanks Nick, It worked this morning.
What limits the folder that are reflected as shared?
Can this be expanded to the entire device? like root and all?
Not worried at the moment to security as it’s only me

The file smb.conf https://github.com/home-assistant/hassio-addons/blob/4ae58927ce2d29b1b0af0d374a6675a3dac6128c/samba/smb.conf.

Whether you can set this as a user I am not sure.