Hassio visible in network but web gui not accessible

Hi,

I am quite new to hassio and I have the following problem:

I falshed the hassio image on a 32GB SD card and I use it with my raspberry pi 3 model b+.

I can see hassio in my network when I logon to my router but I cannot access the webgui via :8123.

I only see a right light shining on my raspberry.

I already tried the following:

  • other SD cards, all class 10
  • accessing via http://hassio.local:8123/
  • both of the images: Raspberry Pi 3 Model B and B+ 32bit (recommended) and Raspberry Pi 3 Model B and B+ 64bit
  • waiting more than 3 hours and not just 20 minutes after first installation

When I insert the SD card to my raspberry pi I see a couple of booting activities cause the green light flashes a couple of times but then it ends up that the red light is steadily on.

For me it’s strange that I see hassio in my network but can’t access the webgui.

Any ideas what I made wrong?

Try accessing http://your_pi_ip_address_here:8123/

A note about this used to be in the getting started page, and it appears someone removed it at some point…

Hi Tom,

thanks for your help.
I tried this but unfortunately the webgui is still not reachable.

BR

Can you ping the pi from the PC you are trying to access it from?

Hi Tom,

yes, this is possible and I get a response from the pi.

BR

Don’t bother with 64 bit image.
The first thing you should see is the “setting up” page at ip_address:8123 and this should appear within minutes of booting the pi.

You can connect a keyboard and monitor directly to the pi to login as “root”. You will arrive at the Hassio CLI. From there, you can type “login” and continue to the host os. From the host console you can check network settings using nmcli, and check the time/date with date.

Hi cogneato,

if I type in login I get asked for a password. I don’t know which one to use.
Can you tell me?

EDIT: Forget about. I was able to login. If using root as username no password is needed.

I try your steps now

If I type in “nmcli” as a command I get the error message “unknown command for hassio Error while executing rootCmd”

When you are at the Hassio cli (you’ll see a hassio > prompt), you can type “login” and continue to the host os where you’ll see a # prompt. That’s where you can use nmcli.

Thanks. I just did this and now I see the current date in UTC.

Apr 29 20:20:46 UTC

My local timezone is 22:20:46 MESZ if that matters

What will be the user and password for login through hassio cli

I mean to login to use nmcli

You login as root. There is no password. When you reach the Hassio cli you type “login” and hit enter to get to the host console where you can use nmcli.

Im not able to login to host while ussing ssh to connect to hassio. The default prompt i see js core-ssh:~# and if i type login here it doesn’t let me in.

Is it something only available when connected directly to the rpi and not in headless mode?

Because you are using the add-on.

Correct. You are INSIDE a docker container, not on the host.

No. You can connect to the host.

https://developers.home-assistant.io/docs/en/hassio_debugging.html#ssh-access-to-the-host

1 Like

Thanks for details. Got it now

Hello Lalit,

Can you tell me what the solution was? Everybody with an problem like this will take a look in this ticket.
But there is no solution?

I hope you can tell me how you solved the problem.
Kind regards, Thetmar Wiegers

1 Like

I also wonder what the solution was. I just restarted the system and now I cant reach it anymore. If I ping the ip it works.

Same problem here. After restart I can’t reach the home assistant via IP or host name.
But it is reachable via the remote access (nabu casa / home assistant cloud).
Any suggestions?