Hassio VMDK in ESXi 6.5?

Hi all

I’m trying to test Hassio on an Intel NUC i3 with ESXi 6.5 to understand if then I can move my actual RPi3 installation.

I’ve installed ESXi and now I’m fighting with the VMDK installation in a VM.
I’ve downloaded from here.

Then, I’ve created a New VM as ESXi 6.5/Linux/Other Linux (64bit)

I’ve uploaded it to the datastore and then from the console I’ve done
vmkfstools -i hassos_ova-1.13.vmdk whatever.vmdk

The config is

I replaced the Hard Disk 1 with a new one connected to the whatever.vmdk file generated before.

In the VM Options I changed this to EFI

and then this is what I get, sometimes it ends to the penultimate row, sometimes to the last one.

What can I check/change more?


Maybe unrelated, but in vbox the image was fussy about network card emulation. I chose the most generic intel emulation and it worked.

In ESXi I can’t choose Network Adapter, the only one is VM Network, I’ve also set Passthrough, but nothing changed…

If you click the small triangle to the left of network adapter you get more options.

Ill check my install when I get home to let you know which one I am using.

There are these three choices.

I’ve tried with all of them, but same result.

I found that there are packages to install (even if I don’t know how to do it!), and thi is the list filtering for “netw”

“Intel PRO1000 Network Driver” should be the one installed.

Again, VBOX may not be relevant, and your problem may be completely unrelated, but FYI the emulated card that works in VBOX is Intel/PRO 1000 MT Server (8254EM).

Thanks, I’ll keep in mind and try to find other Network card to load in the VM.

Regarding VBox, is it correct that if the the phisical server goes down, then the VM does not start automatically?

I looked at this some more. A couple of things are clearish:

  • the last couple of things in the log are not necessarily related to the freeze. A lot of kernel loading and hardware booting is backgrounded, so some backgrounded module could fail at any time.

  • that said, on my vbox system, there is both network stuff and disk mounting gong on just after the point where your system seems to freeze.

So we are no further ahead, just wanted to point out that debugging this shit is not easy!

1 Like

I am running hass.io in a fresh ESXi 6.7.
I started off with with a default 64 bit Ubuntu install using the default image (ubuntu-18.04.1-live-server-amd64.iso)
I then ran this script : goo.gl/goR2HT
Which installed everything. It runs flawlessly for about a month now. I also connected a USB device (RFlink 433 MHz transceiver) to hass.io.
Hope this helps.

1 Like

Thanks @pathia

What server/PC do you have to run 6.7 version?

Sure, np.
A Dell optiplex 9020 stuffed with 32GB ram and a rather small SSD disk of about 200 GB.
You can view some stats here:

Been running HASSIO on ubuntu on ESXi6 for ~2 years now (since whenever hassio came out).
Followed the same install process from here:

Running on Dell T20 (cheap intel xeon) with a VM with 1 core and 4gb RAM IIRC.

I would like to have ESXi 6.x with Ubuntu Server and Docker in it.

I would like to have Hassio installed in Ubuntu server (and most of its addons installed together) and Node-Red installed in another container, in the same Ubuntu Server, and let it work with Home Assistant node.

Is it possible?

Yes. its possible and I do this. I decided have two ubuntu VMs with docker - one running hassio, and one with other non-HA related containers, but you could do it all in one VM if you prefer. Sometimes I need to make decision whether I will use a hassio addon or not. e.g. Unifi controller I decided to install in my other docker. Node red I decided to use the addon.

I tried in a ubuntu server and I was not able to connect from NodeRed the Home assistant server with error “Cannot GET /homeassistant/entities”, but I will try again

I’m afraid I cannot help on that specifically as I made the decision to use the node red hassio addon. I decided based on the fact it installs the HA nodered stuff, syncs users etc. i.e. added value over rolling my own. Also I will use NR only for HA.

I confirm the error, I’ve tried all the node available for Home Assistant (one at a time), and they all give me an error when I define the HA Server using the IP address and the API key (or Long Lived Access Token).


Anyone who is using this configuration, two different containers, one for HA (or HASSIO) and one for Node-Red?

node red is just another MQTT connection to the broker. If you log on via ssh to the docker host and type ‘docker container ls’ you will see all running containers along with their port forwardings. For MQTT I guess you will see ‘>1883-1884/tcp’ which basically says translate incoming port 1883 to to the container’s ip and port 1883. So basically a 1 to 1 mapping.
You should then be able to make a MQTT connection to the ip of the docker host on port 1883.
If you type ‘docker exec -it nodered /bin/bash’ or ‘docker exec -it nodered /bin/sh’ (replace nodered with the actual container name) you will get a shell inside the docker container. You could try to telnet to the docker host on port 1883, which is basically a test from the exact same place like nodered does.

telnet or netcat are not found within the container.
I’m using Portainer as container management, and I can see that both Node-RED and Hassio are in the same “bridge” network.

I’ve tried also to install via “apt-get install telnet” but, I get also nothing to install…

I’ve tried using the internal network address, but no success.

I think I will try to open a more specific thread (after searching more deeply).


Why another container for nodered? If you use hassio plus the addon it is in another container anyway.