Hassio Zwave Read Only?

I have completed the setup of my homeassistant server. I used the hass.io image and mhave added the appropriate config to my configuration file:

usb_path: /dev/ttyACM0

The zwave component shows up in the web interface. It appears as if it is read only. I can see the states of all of my zwave devices. When I turn a switch on, that change is reflected in the web gui. However, when I attempt to turn a switch on or off via homeassistant, the switch toggles for a moment, and then goes back to its original state. Any suggestions?

1 Like


1 Like

Unless you have a Zwave switch with “instant feedback” (my term not the manufacturer’s term) you will need to enable polling to get state updates in a timely manner. See the docs. https://home-assistant.io/docs/z-wave

Going back to it’s original state suggests a communication problem between HA and the Z-Wave node.

If you look in the states menu (<> - under Developer Tools) at the Z-Wave nodes, are their states all Ready or Sleeping?

I’m not having a problem with viewing updates. If I manually turn a switch on, that change is reflected immediately in homeassistant.

I have 5 total devices on my network. A zwave stick, a range extender, two dimmers, and one switch. The statuses in the developer tools matches the attached screenshot.

You’ve got 4 Dead nodes, those are nodes that Home Assistant can’t communicate with.

You need to place another range extender between that range extender, and those devices, or relocate the range extender.