HassOS 4.13 to 4.14 update broke Bluetooth presence detection

Just updated OS from 4.13 to 4.14 and now my phone with bluetooth presence shows away
all of the time.
Have tried restarting HA and turning phone off and on but it now always shows away.
Worked perfect upto 4.13 with no issues.
Running on Rapberry Pi 3B+

Had this happen back when OS went from 3. something to 4.0.

Is their an easy way to roll back to 4.13 until it’s fixed?
I have a backup but its older and would have to do alot to get it current.

Seems like Bluetooth is buggy or broken in HassOS 4.14. There are issues reported on github:

And yes, you can downgrade:

1 Like

Yes, I also encountered difficulties as soon as I switched from version 4.13 to 4.14
First in all integrated BT-Xiaomi entities, then in the integration of smart devices connected via Bluetooth such as teapot, where when scanning it had to be found and specified, but the scan left the fields completely empty, so it became clear that Bluetooth as a module does not work completely.

Ran the cli command to roll back to 4.13 and everything working good again.
Also had issues listed in another post with ZHA motion sensors with 4.14 now
also working fine again with 4.13

Thanks…

Same here. Could you share the cli command to roll back to 4.13? Nevermind, the command is ha os update --version=4.13

I can confirm that after rolling back to 4.13 all my BT integrations are working as expected

1 Like

thanks for sharing the command, all BT’s status updates are back again, painfull when they are not updates anymore

eq3bt climate is also broken with 4.14, rolling back solved the problem.

HassOS 4.15 fixes issue.

Just updated to 4.15 with supervisor 249 and tested, Bluetooth
is working now.

Same here.