HassOS and Google Assistant

OS: Home Assistant OS 5.13
Home Assistant Core: 2021.4.1

I have both addons for “Let’s Encrypt” and “NGINX Home Assistant SSL proxy” addons, which seem to be working fine (I have an static IP, port forwarding on my router, and an external domain name). Everything has been working well since I switched to HassOS a few months ago.

I have HassOS running on a Raspberry Pi 3, and am setting up Google Assistant.

I’ve tried following the directions found at https://www.home-assistant.io/integrations/google_assistant/ but am having some troubles getting Google Assistant working.

When trying to add devices through the Google Home app on Android, I get
“Error: invalid client id or redirect uri.” I’ve tried the trouleshooting steps referred to on the instruction page, without success.

I have checked various support and documentation pages, but am not able to correct this. I believe it may have to do with the “NGINX Home Assistant SSL proxy” addon.

I also notice that I receive an error on Home Assistant stating “Login attempt or request with invalid authentication from core-nginx-proxy.local.hass.io (”

I’ve tried adding the “use_x_forwarded_for: true” and “trusted_proxies” settings but without success. I’m not exactly sure what is causing the authentication errors.

Maybe Google Assistant integration isn’t using the json credential correctly? I would find that strange.

To troubleshoot why the Home Assistant isn’t letting Google Assistant get the proper token/auth for adding devices to Google Home/Google Assistant, what things should I be looking for? Any ideas or suggestions appreciated.