HassOS - Can't install homeassistant/raspberrypi3-homeassistant:0.111.4 -> 404 Client Error: Not Found

Tags: #<Tag:0x00007f32615e49b8>

No idea why I’m getting this error, but I’m unable to update. I have plenty of available space on my SD card (21.2 GB free of 28.5 GB)

Raspberry Pi 3b
HassOS 4.10

The docker hub says it’s available… but I’m having ‘unknown error, see logs’ returned.

https://hub.docker.com/r/homeassistant/raspberrypi3-homeassistant/tags

Error log for reference:

20-06-24 00:21:18 INFO (MainThread) [supervisor.homeassistant] Update Home Assistant to version 0.111.4
20-06-24 00:21:18 INFO (SyncWorker_19) [supervisor.docker.interface] Update image homeassistant/raspberrypi3-homeassistant:0.111.0 to homeassistant/raspberrypi3-homeassistant:0.111.4
20-06-24 00:21:18 INFO (SyncWorker_19) [supervisor.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.111.4.
20-06-24 00:21:20 ERROR (SyncWorker_19) [supervisor.docker.interface] Can’t install homeassistant/raspberrypi3-homeassistant:0.111.4 -> 404 Client Error: Not Found (“no such image: homeassistant/raspberrypi3-homeassistant:0.111.4: No such image: homeassistant/raspberrypi3-homeassistant:0.111.4”).
20-06-24 00:21:20 WARNING (MainThread) [supervisor.homeassistant] Update Home Assistant image fails

just had the same error. I searched the web a bit and it could be that you have not enough free space like me. I am running Home Assistant as a VM in Hyper-V and was able to enlarge the virtual disk and it was recognized and i could update afterwards.

You could check this with running the command “df -h” with “SSH & Web Terminal” Community Add-on. (You need to install the Add-on > Configure a password > open Terminal > type ‘login’ then ‘hassio’ then your password and then type ‘df -h’ and check free space.

The following Links may help solve if it’s free space problem:

I’m having the same problem. I removed a bunch of snapshots I had and df -h says I have 7.8G free but I still can’t download the update. How much free space is needed?

Any more ideas?

Here’s what that returned… as mentioned, lots of free space available.

SSH in to the host ( not the HA container)


and issue the command
docker pull homeassistant/raspberrypi3-homeassistant:0.111.4

Post the error message here.

I cannot get this to work for the life of me… it won’t let me log in.

I’m doing the following from a windows 10 laptop. I have the Terminal & SSH addon enabled on the Web UI.

Here’s the steps I’m doing:

  1. In PuttyGen, I opened my private key I created a few months ago to set up SSH in HA
  2. Copied the text from ‘Public key for pasting into OpenSSH authorized key file’ into a blank text file that I named ‘authorized_keys’ (no extension).
  3. I put that on my NTFS formatted USB drive named CONFIG
  4. I went to Supervisor / System in HA, and clicked ‘upload from USB’
  5. In the SSH webUI window, I typed:

ssh [email protected] -p 22222

The system returned:

The authenticy of host '[mylocalHAipAddress]:22222 ([mylocalHAipAddress]:22222)' can't be established.
ECDSA key fingerprint is (LETTERS & NUMBERS REDACTED).
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '[mylocalHAipAddress]:22222' (ECDSA) to the list of known hosts.
[email protected]: permission denied (publickey).

I also can’t log in from Putty or my laptop using SSH (searching online this may no loner be an option?)

I also tried entering the command ssh [email protected] -p 22222, but it just says connection refused, and a few other iterations of what I think that the instructions are telling me to do.

I also tried to open a putty ssh session, with the host name homeassistant, homeassistant.local mylocalHAipAddress, etc… with the port as 22222, it says ‘login as:’ and nothing i enter will work.

Ultimately, it ends in error:
2020-06-25 16:30:51 No supported authentication methods available (server sent: publickey)

WHY is this so difficult? Things like this make me want to give up on the program entirely.

Is this because I’m trying to do all this from a laptop that’s on the same network as the raspberry pi? Should I plug in a keyboard to the pi and do it from there?

you should be able to issue this command with the SSH & Web Terminal Community Add-on (not the Terminal & SSH from Offical add-ons) and Protection mode off

! and make sure you first deinstall the offical add-on if installed !

(and i think you have to set a password under Configuration in the add-on, login with ‘hassio’ and your password)

1 Like

Nice catch ! Did not know that one :slight_smile:

i figured it out the hard way :slight_smile: struggled like @Traxtar944 to set-up SSH (for bluetoothctl) from Developer Page and was looking for an easier way.

The error results.

failed to register layer: error creating overlay mount to /mnt/data/docker/overlay2/xxxxxxx/merged: too many levels of symbolic links

By the way, that SSH community addon is the same one I was using before. Still can’t login to the OS.

I’ve been googling on

too many levels of symbolic links

but it turns out mainly with unanswered questions. One constant : a circular reference somewhere.

What version of HA are you running now ?

pvizeli mentioned here https://github.com/home-assistant/docker/issues/108 that the command

ha su repair

followed by pi restart could solve such issue.

In another forum, not related to HA, someone said that the image he pulled was corrupted (or corrupted during pull) and he deleted the incomplete image and new pull worked. (but i don’t know how to do this, could be “docker system prune” command or something, maybe someone else can help here)

Another thing you could try is to JOIN BETA CHANNEL and try to update to a beta version.
Make sure you create Snapshot or Backup before.


(i read somewhere that so. was able to pull another version without problems)

I’m running 0.111.0 Core, Supervisor 227, and HassOS 4.10

My google searches returned similar results.

ha su repair

Does not work. It completes successfully, but still cannot update. No observable changes.

If I could somehow clear out the update and re-download, I’d definitely try it. I still can’t log into the OS via SSH, so that might be the next thing I need help figuring out.

Update to 0.112 core was successful.

1 Like