HassOS crashing after a few hours after a clean install


I’m fairly new to Home Assistant, I’ve been running HassOS on a Raspberry Pi 4 (4gb) for about 3 months now, and have had pretty consistent crashing issues. I’m not sure exactly when the crashing symptoms started because it’s been so long now, but it started off crashing every day or two, and now is crashing every few hours. My set up has never been to complicated, I have some of the basics set up like DuckDNS etc. and using a Conbee adaptor to communicate with a couple of Aqara devices that I have. Everything works pretty great except for the crashing.

I’ve read through a few similar posts and a lot of the advice was to try a better SD card, but I’ve tried a different SD card with a fresh install of HassOS and it’s still crashing after a few hours. I’ve reflashed it a few times using the latest image whilst trying some different things with no luck. I also recently tried the same SD card with Rasbian on it for a few days without any issues, so it looks to be something specific to HassOS (which doesn’t rule out my SD cards, but it’d be bad luck to have 2 dodgy SD cards).

At the moment I’ve stripped everything right back, nothing plugged in except the Ethernet cable and the power (and on a second reboot added HDMI to view the console when it crashed) and it’s still not lasting more than a few hours. Given that this is a brand new image it doesn’t seem to be specific to my HassOS config, but given that Raspbian worked flawlessly it doesn’t seem to be hardware related. It’s also the same symptoms on 2 separate SD cards so it doesn’t seem to be that, and I’m left without any further things to troubleshoot. Does anyone have any ideas on where to head from here?

When it crashes I can’t get any response from the device and the router loses it as well, which is a little bit different from some of the other crash reports I’ve seen.

For good measure, here’s a photo of the console output. Unfortunately I’m not clever enough to get any useful information from this other than there was a kernal panic.

Thanks in advance!

Im really sorry that I don’t have a solution. I’m having the same problem. I’ve had numerous SD card failures, despite changing to good quality cards and using MariaDB, so decided to go to an SSD. That took ages to get working after trying an RPi 3B and 4. And now my RPi 4 running HassOS v5.0 64-bit lasts maybe 20 minutes and acts similar to a faulty SD card. No SSH or front end, can only ping.

Honestly I’ve had nothing but problems with Hassio since starting with it late 2017. It works great until one day it just doesn’t. I can’t rely on it for basic things.

It may not be the SD card.

there have been reports of excessive CPU usage on v0.113.

Add a CPU utilisation sensor and check.

If this is the case roll back to v0.112.5

ha core update --version=0.112.5

I tried this to try and get some useful troubleshooting data, but the CPU usage sits pretty comfortably in the double digits, and probably more importantly here, I’ve been having this issues from before v0.113, I think it might’ve started around v0.109? I was hoping that updates would assist but unfortunately not in this case.

For what it’s worth, as a an alternative I’ve tried a Manual installation on top of Raspbian and it’s yet to crash, 12 days in. My setup is simple enough that I don’t need Supervisor (yet!), and I’ve enjoyed manually installing anything that I need. Tinkering is what brought me here in the first place after all :slight_smile:

Not sure why HassOS personally hates me, but I think for now I’m set with Home Assistant Core.

Well I’m glad you found a solution.

Oddly enough I found, in my situation, that the freeze-ups was caused by recorder. As soon as I started using a MySql server (running on another host), the high cpu usage and freeze-ups stopped occurring with CPU usage dropping approx 75-90%.