HassOS does not support RPI 4 - 8GB

Using a new Raspberry Pi 4 Model B – 8Gb

Connected to router via ethernet cable and the router supports DHCP

I followed the instructions to write the latest hassos_rpi4-4.10.img to a 64GB A2 SD card

I can’t get past the initial boot which continuously cycles through 5 steps:

  • A start job is running for Wait Until Kernal Time Synchronised
  • A start job is running for HassOS ZRAM tmp
  • A start job is running for HassOS ZRAM swap
  • A start job is running for HassOS data resizing
  • A start job is running for HassOS ZRAM var

I’ve attached relevant screenshots.

I don’t need a network configuration according to the instructions (happy to use DHCP via ethernet) but also tried with a network config on USB but made no difference.

Pretty sure I followed the instructions correctly, anyone able to advise what I missed?





For anyone else experiencing a similar issue, I have changed the title of this post as it has been confirmed that the 8GB model of RPI 4 is not currently supported:

I know I’m not supposed to do it (it’s not debian) but I installed ubuntu 20.04 server 64bit on my RbPi 4 8Gb, and HA Supervised is running fine :slight_smile:

Has it been confirmed that the 8Gb Pi4B model is currently being worked on for Home Assistant?

I wonder about this as well.

@Tpm369, did you already try the way @francisp suggested? Anyone else already experience with the Pi4B 8Gb?

Any chances this is close for a release?
I just received my Pi that I want to use just for HA.
I’ve tried temporarily putting it in a docker, not realizing that I cant run the supervised version this way, so I suppose I am back waiting for a release to be issued.

LOVE your work

There is a pre-release of HassOS 5.0 available now. It supports RPI4 8 GB and USB-boot on RPI4 (only for the 64-bit version of the OS).

For USB-boot, read the documentation and make sure to update your PI4 with the latest eeprom firmware. 2020-07-16 firmware worked for perfectly for me at least!

3 Likes

hey!
im trying this myself, however i keep getting the Timeout waiting for hardware CMD interrupt message.

i did edit the config.txt file - however im not sure this is the correct place, as i was doing that on the RPI OS, which is on the MicroSD, that was removed, so i can boot from the SSD (which has v5 of HassOS)

what steps did you follow to do a clean boot of HassOS from an SSD?

Just to be sure: Are you using RPI4?
In that case, you should update the rpi eeprom to enable USB boot. It is not done in config.txt.

Read the documentation: https://github.com/home-assistant/operating-system/blob/3fe09a4e6afa4c184a585c51a9a58c980f79fb38/Documentation/boards/raspberrypi.md

hey! thanks for the quick reply
yes, running rpi4, 8GB

so ive got RPI OS on my MicroSD, which boots fine.
on that, ive edited the boot\config.txt file, to include “dtparam=sd_poll_once=on”

i then did a reboot
i checked (more config.txt) that the entry was there

i then pulled the power, removed the SD, then added power, but thats where i keep hitting the error

also

bootloader version = July 16 2020

bootloader config =

[all]
BOOT_UART=0
WAKE_ON_GPIO=1
POWER_OFF_ON_HALT=0
DHCP_TIMEOUT=45000
DHCP_REQ_TIMEOUT=4000
TFTP_FILE_TIMEOUT=30000
ENABLE_SELF_UPDATE=1
DISABLE_HDMI=0
BOOT_ORDER=0xf41

ah, got it, used this and it seems to come up

Thank you so much!

Sounds like a STUPID noobs question BUT:
Where can one download the pre-release image for PI 4 8GB?

Thanks again for everything you and your team do!

1 Like

Click on assets and download the correct image.

2 Likes

Thanks @ASNNetworks!

New to HomeAssistant and bought the 8GB Raspberry Pi 4B.

Using the Pi OS I ran the boot loader update utility to grab the soon to be released version suggested by eric73 and updated the board. I then flashed the HA 4.11 version from the HomeAssistant web site and it is running fine.

1 Like

Do you have any instruction for that? Thank you

1 Like

Here is what I did (as best that I can recall)

  • updated Pi OS to get the current EEPROM utility

  • edit ‘sudo nano /etc/default/rpi-eeprom-update’ and change from ‘critical’ to ‘beta’
    $ sudo nano /etc/default/rpi-eeprom-update’

  • run and confirm you see the updated July version
    $ sudo rpi-eeprom-update

    CURRENT: Thu 16 Apr 17:11:26 UTC 2020 (1587057086)
    LATEST: Thu 16 Jul 15:15:46 UTC 2020 (1594912546)

  • Install the updated EEPROM image and reboot
    $ sudo rpi-eeprom-update -a
    $ sudo reboot

  • Check it is installed
    $ sudo rpi-eeprom-update

    CURRENT: Thu 16 Jul 15:15:46 UTC 2020 (1594912546)
    LATEST: Thu 16 Jul 15:15:46 UTC 2020 (1594912546)

I then flashed the latest HomeAssistant image on the SD card and it worked as it should.

1 Like

Any update on this? I tried the steps above from @sillygoose and it did indeed update to the latest eeprom (July 31 in my case), but when I try booting to HA it still just boots to the same screen as mentioned by the OP. I have tried HASSOS versions 4.12 and 5.1. Both had the same result.