HASSOS not seeing my TPLINK switches since moving to it this week - was working before


It’s strange but I had my HS-100’s working in previous versions including the docker container version I installed 8-9 months ago. I use actions to monitor the house temp for our animals and turn on/off the window air conditioners. My first set was setup in 2019.

Fast forward to this week where I decided to go back to HASSOS and now after the fresh install, the TPlink integration can’t discover any of the devices (yet Alexa can) and when I manually configure them in the configuraiton.yaml it does not see them.

Any suggestions?

These no longer need configured in the configuration.yaml and instead can be setup in the UI with auto-discovery. Just make sure it has a static IP address in your router and add the integration from the UI.

Unfortunately, that is not working either. I have around 10 (all static IP’s assigned from my firewall) on my wifi network and have Hassos on my ethernet (RPI 4).

When both the ethernet and wifi are configured on HASSOS (both get a static IP from my firewall) discovery still does not work.

Try restarting Home Assistant. For me, that’s when discovery is most likely to work.

I’ve rebooted it a few times (been googling for over a day now before posting here).

I just added the terminal and ssh add-in and see that the system is getting IP addresses on both interfaces.

Rebooted again and no joy. It did not auto discover and when I enter one of the devices IP addresses as a host, that did not work either.

I use these to run the window air conditioners for my pets when I’m away. Temp goes above a certain point it turns on the air. Drops down and turns it off to save noise and power.

Any other suggestions? I may try disconnecting the ethernet to see maybe if the discovery is only going out that interface as ethernet has a higher priority than wireless.


I went into the networking section of HA via the web interface. While I did have the WLAN0 configured and it said connected, HASSOS was not enabling it.

To fix this what I did was scrolled all the way down in the networking section (settings → system → network - network adapter) and unchecked the auto-detect while ensuring both interfaces were checked.

It’s using the ethernet as the default and now when I scan it is finding two of the devices. I’m going to see if I can get it to add the rest.

At least I have one of the window shakers setup :slight_smile:

1 Like

Something I had to do in the past was factory reset some devices, set them up in the Kasa app without logging in to run in local mode, then discover them in HA. Others were found while tied to my Kasa account. Weird.

I left it for a few hours while I was on conference calls and all of a sudden it was able to see them.

Mind you I had to add the integration back in 8 more times, one for each device as it would only let me add one at a time in.

Now I am working on re-creating the automation. Timers for electric heaters, temp based on/off for the air conditioners, etc.

Interesting that HASSOS does not automatically activate the wlan when you scan and add the WPA-PST key. Learned something new today.

1 Like