HassOS on SSD

Tags: #<Tag:0x00007fc42fb061e8>

Wait - is this true?! we can finally boot directly from an USB drive?! No Docker or other shenanigans?! Simple, plain old HassOS?!
Does it also work with the RPi 3B+???
Dreams do come true!

well docker is integral part of hassOS and this worked for the Pi3 already for a long time.

It did?!
What kind of “long time” are we talking about?! I last tried to do that early 2020 - but then it was only possible to install home assistant in a virtual machine running on the pi (if I understood correctly) … But now (starting with HassOS 5.0?!) it’s the same thing as running it on a SD card, right?!

1 Like

Which HassOS version should I use for a RPi3 B+ ? Does the latest stable 4.13 work too, or do I need to use 5.x?

I am not sure what you are talking about. I was able to install HassOS 4.x on a RPI 4 via SD card last year without a problem. And a Rasbian OS based HA installation also worked on SSD with a SD card to boot since last year. that was exactly my setup since last week.

Unfortunately I cannot recommend anything for RPI 3 because I don’t have own experience here.

I have the same question- is the dev version (5) needed to run Home Assistant (HassOS) from an SSD, or does this work with HassOS 4? I’ve followed the threads but am confused still. :man_shrugging:

No, it does not work.
The only possibility to use HassOS 4 on SSD with a Pi 4 is to use a SD-card to boot and have the data-partition on the SSD.

2 Likes

Thank you! So for people like me who want to switch to SSD because of previous SD issues, but are in no rush, we can simply wait till HassOS 5 is in production? :slight_smile:

I would say so!

1 Like

So news?
Boot from SSD in RasPi 3 B?
I tested also LATEST 5.4 DEV but screen stay black and no video signal.
So still boot from sd and data in ssd? I read that is possible to boot from SSD!
Maybe the problem is only for Hassos?

That should be possible also in older versions of HassOS I thought. Because the 3B can boot after a not reversible patch (don’t ask me how it works!) from USB.
The 3B+ can boot from start from USB.

Hi,
I used this guide


and also i did check with this command and checked the result
$ vcgencmd otp_dump | grep 17:
17:3020000a

So now I cold boot from ssd… but not work (also tested ubuntu and raspbian distro)

Works like described with hassos 5.5. Perfect, thanks for the description.

Thank you for posting this.
I was going to give up until I decided to try 4.13 (although for my Pi 3B) and it worked.
Looking at the current open issues like this one: https://github.com/home-assistant/operating-system/issues/1095 , it seems there is something wrong with recent boots.

I had a problem with a firmware update that resulted in that the UBS drives were powered on a bit too late for “normal” booting, on one of the later boots

The work around is to start the PI without SD card and disconnected SSD drive and then connect the SSD drive after a few secounds.

2 Likes

Goodday,

My goal is to boot/run Homeassistant from a SSD on a RPi4, I purchased a 128Gb SSD but it is NTFS formatted. Windows (10) gives me only 2 options to reformat, NTFS or exFat… Do I need to reformat ? and if yes I think this must be FAT32 ?, any windows tools out there that can do the job, Thanks in Advance, Frank

You don’t need to „format“ the SSD. You only have to use the „Raspberry Pi Imager“ which is available at raspberrypi.org.
With this you can simply write the image of HassOS onto the SSD. That‘s all.

Thank you !!..

Regards Frank

Somehow I cannot boot from my SSD directly. I am using the Raspberry Pi 3B but can only boot from SD. I am using a WD Green SSD and a ICY BOX USB 3.0 SATA Adapter. Any idea why this is not working?

For the 3B you have to make something inside the Pi to let it boot from USB. If I remember correctly there has to be flashed something which is not reversible.
Only the 3B+ can boot directly without any change.

These older Pi only have USB 2, so there is no problem with the USB-SATA Adapters as they are not used in the faster modes (UASP) which sometimes are a problem on the Pi 4 and USB 3.