HassOS on SSD

Just bought Raspberry 3B+ and want to boot HassOS-image from USB-SSD.
I’ve tried to install the HassOS-image on SD, moved the hassos-data partition to SSD. (see this manual) I didn’t need to changed the OTP-bit, because it’s a RP3B+. But the RP3B+ it didn’t start up.
My hardware: RP3B+, powersupply 3A, 32GB Micro-SD, Crucial M4 SSD 2,5" and a Sata to USB3-cable (link)
I’ve read some comments that it’s not possible yet?
I’ve read something about bootcode.bin and timeout file.
I dont want to use Raspbian & Docker.

Can anyone help me with a manual for installing HassOS-data on USB-SSD?

1 Like

There is already a thread on this. You should search the forum.
Official documentation is here:

I’ve read the answer above. Can you tell me more how to configure SD-card when needed and SSD? I’m not a Linux-proffessional. :wink:

This work for me (wrote done all steps)

**Build a HassOS on SSD - “program_usb_boot_mode=1” already done on RPi

Download latest build from this URL:

Burn image on your SSD with Balena etcher

Format a SD-Card with FAT Partition, give it the name CONFIG

Goto the SD-Card and do follow commands:

mkdir network
cd network
nano my-network

Copy/Paste this part below and change your SSID and PSK with your own Wifi information:




Put your SC-Card in RPi and power your SSD! Otherwise it won’t work
Then power your RPi
What for some minutes 8-20 minutes
Try to connect to the Hassio link:


If this is not working then search for the IP thats connect to
Setup your HA!!!

Then follow the steps in this link:

Install SSH & Web Terminal Add-on from the Hassio Community Repo

nmcli radio
nmcli device wifi rescan
nmcli device wifi
nmcli device wifi connect "YOUR_SSID" password "YOUR_WIFI_PASSWORD"

This will try to connect to your SSID and will generate a network profile for you if successfull.
The output will be similar to

"Device 'wlan0' successfully activated with...."

nmcli con show
nmcli connection delete CONNECTION_NAME
ip addr show

Optional: Restore Backup

1 Like

Put your SC-Card in RPi and power your SSD! Otherwise it won’t work
Then power your RPi.…”
I’m using a USB-SSD (SSD connect to Pi with a single SATA to USB-cable). Will this work too?
How do i power my SSD before i power my RP3B+?

How can it? I dont see you anywhere setting the “program_usb_boot_mode=1” that at least the raspberry 3 needs. Not sure about the rpi 4, last I checked it couldnt boot directly from usb at all. Am I missing something?

Sorry the steps are for my archive… I have my RPi3B+ already done with “program_usb_boot_mode=1” in past. So then its not needed anymore.

Second to @hassio-martin I don’t know if it will work. I have a SSD also connected to RPI using USB. But powered with external Power Supply. There are cables that have 2 USB connections, 1 to connect and 1 for external Power.

FWIW, i have been trying with a USB Sata dock (externally powered), and a sata ssd freshly etched with balena etcher with the latest RC, and its not working. Not sure if I did something wrong, or the sata dock doesnt work with the pi. I read somewhere to copy bootcode.bin to an sdcard, but I cant locate that file on the ssd…

Did you download the right Hassos? Everywhere you read download latest from link. I posted also the link…

what the difference between your link https://github.com/home-assistant/hassos/releases and https://www.home-assistant.io/hassio/installation/ ?

https://github.com/home-assistant/hassos/releases works on a RP3B+ with USB-SSD attached. No SD-card needed.

You don’t create CONFIG or a my-network file and use my guide. They are two different choices to achieve the same thing.

1 Like

I did indeed get the wrong hassoss image. My pi3 now boots from USB with no problems, but Im having a hell of a time migrating my config over. Ive tried restoring a snapshot, copying the config folder via samba, copying the homeassistant folder on a different linux machine, everything results in HA not starting or not remotely working properly. What is the correct procedure?

anyone succeeded install on ssd with raspberry pi 4 hassOS ? My SSD does not boot or showing activity lights when i turn on raspberry pi … ssd connected with usb cable…

or do i have to wait for a ssd support for the pi 4 ?

Here works perfect. Use SD to boot and rest boot from root on SSD

How did you do it ? what image did you download ? pi 3 or 4?

This worked for me perfect. Tried this couple of times to be sure this is working. Now running for 3 months Hassio on SSD on RPi. Only first boot part from SD

Flash on SD Card Debain Buster Lite Image put in RPi4 and bootup

Now do some things on command prompt of Buster on your Pi:
(In my case my SSD is /dev/sda1, it can be different ar your setup)

sudo mkfs.ext4 /dev/sda1 -L root
sudo mkdir /media/newdrive
sudo mount /dev/sda1 /media/newdrive
sudo rsync -avx --progress / /media/newdrive
sudo nano /boot/cmdline.txt

Copy the full line in the cmdline.txt so you have 2 same lines. command 1 out with #
Replace the second line the “root=“ see below.

root=/dev/sda1 rootfs_type=ext4 root_wait rootdelay=5

Save the file

reboot now

If you have something with resize, remove that part also.

Correct location and timezone


Install Docker

sudo -i
apt-get install software-properties-common -y
apt-get update
apt-get install apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq socat
curl -fsSL get.docker.com | sh

Install Hass.io

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s -- -m raspberrypi3

After about 20 Min login via WebUI. Create account


Are you using a PI3 installer for a pi4??

Since August 2020 it is possible to directly boot your ssd attached via usb on a RPI4 without a SD card. Finally a firmware Update on the RPI opened this door.

And HassOS 5.2 (64bit Version) finally boots from SSD.

To use this feature you need to run the latest eeprom update.

Steps (source: boot-raspberry-pi-4-usb)

  1. Boot from a standard microSD card with the latest Raspberry Pi OS on it.
  2. Update your OS and firmware by typing:
    sudo apt update
    sudo apt full-upgrade
    sudo rpi-update
  3. Reboot the Raspberry Pi 4
  4. Install the latest bootloader by typing
    sudo rpi-eeprom-update -d -a
  5. Reboot the Raspberry Pi 4 again.
  6. Launch raspi-config
    sudo raspi-config
  7. select Boot Options (item 3) - press Enter
  8. Select Boot Rom Version - press Enter
  9. Select Latest and then OK
  10. Select No to not Reset boot ROM to Defaults
  11. Select Boot Order and press Enter
  12. Select USB Boot
  13. Select Finish to reboot
  14. Download HassOS 5.2 or later 64bit version (HassOS 4.x will not work) from here
  15. Now use Balena Etcher or a similar program on your Desktop Computer to copy HassOS 5.2(64bit) or later on your SSD
  16. Connect your SSD to the RPI4 via USB3.0 Connector
  17. Remove the SD card and reboot

Your PI should now boot directly from SSD and installs hassOS


I had it working on a Hassio 5.1 I’ve updated to 5.2 and I got a completely black screen after the splash screen.
I tried this method installing

Raspberry Pi 4 Model B (1 GB, 2 GB and 4 GB model) 64-bit

and I have the same result.
reflashing 5.1 or 5.2 worked

1 Like