HASSos seems to be blocking my Tradfri Hub. Hmmmn

TL;DR: When my RPi4 w/Home Assistant is on the network, the IKEA Home app refuses to pair with the Tradfri Gateway. What could be blocking it?

Despite multiple resets, a complete re-image of HA, total network reconfigurations… whenever the RPi is running Home Assistant on my network, the Tradfri iOS app can’t find the gateway. It doesn’t even get to QR code, just ‘Finding…’ before failing. Manual IP search doesn’t work either.

This is also the case when the HA server is entirely stopped, so that points to HASSos itself.

The Gateway can be happily pinged from wired and wireless devices, and can even be fully added to the HA Tradfri integration (though not HomeKit, which fails at the final step). So why not the app…?!

If the Gateway is set up, then Home Assistant started, it continues to work with the IKEA app… but HomeKit stops working. If any changes are made to Tradfri, then the IKEA app stops too.

The only way to get it back is to take HA off the network and reboot the Tradfri Gateway completely, after which all is well again. NB: Running the RPi without an SD card, Tradfri DOES work… so again, points to HASSos. Tried on 116.1 and .2.

Anyone any ideas on what could be causing this?!

Am running a UniFi network (across two switches, have tried same / different switches, checked the IPs aren’t conflicted), if that makes any odds.

Gutted, as a refugee from HomeSeer, and have been LOVING Home Assistant. Sob.


May have narrowed this down.

Wiped and reimaged my Home Assistant from a old snapshot. And the Tradfri app connected to the Gateway!

This snapshot already had the Tradfri integration set up, and a couple of devices added. They didn’t work (Entities unavailable), but this may point to the integration doing something that confuses the app / Gateway on first pairing.

Will raise it as a potential issue, but curious that no-one else seems to have encountered it…