Hassos update failure

Tags: #<Tag:0x00007f7394bd9ed0>

This morning I have upgraded home assistant from 0.110.4 to 0.111.0. When I did so, I noticed that HassOS could also be upgraded to 4.10. So after 0.111.0 was installed, and everything was running again (except for some custom lovelace cards), I pressed the update button on the HassOs.

And since then, my home assistant has been unavailable. I’ve even done a powercycle (“have you tried turning it off and on again?”).

Any advice on reviving it?

(glad I have daily backups)

Are you running a Raspberry Pi 4 by any chance? It seems that 4.10 broke Wifi on that board: https://github.com/home-assistant/operating-system/issues/733

Thanks, no it’s a 3B.

Same issue for me - Pi 3B+.

Any luck recovering?

Not yet…
Have tried a few times more to do a power-cycle, but no luck…

Well, I’m back, thanks to the super efficient backup from @sabeechen (https://github.com/sabeechen/hassio-google-drive-backup, can reccommend).
No clue as to what went wrong, just had to start from scratch, by burning an image on an sd card…
Topic closed afaic…

Glad it worked out for you! :+1:

1 Like

I had to do a similar start from scratch. I pulled the most recent snapshot off the Pi’s sd card, burned a new sd card, and then applied the snapshot. Nothing else seemed to work.