HassOS Update Unstable?

Hey, I wanted to see if anyone is having instability issues with the latest HassOS 2.10? Since I’ve updated, maybe 2-3x a day it goes fully offline until I unplug it and plug it back in. I’m running Home Assistant 0.89.2 on a Raspberry Pi 3B (32bit). Is anyone else having these issues?

No problems with 2.1 here

I have the same issue when ever i try to update to 0.89.2. The update fails, everything goes offline and I need to unplug it and plug it back in.
So for the time I’m still at 0.89.1

Ok, so it’s not just me. I was thinking that maybe it has to do with me using mariadb recently instead of the standard one, and was looking to move to influx if that worked better, but if other people are having the same issue, it’s probably not it. I did find it weird I couldn’t even ssh into docker though, so I figured it wasnt a Home Assistant issue and had to do with the os

i am unable to upgrade from 89.1 to 89.2 as well. mqtt and http go offline. icmp only thing to reply

i’m running hassio with mosquito and ssh. as basic as it comes right?

Mariadb was the first thing I thought also because of the latest update which messed up my database.so I had to delete the database remove mariadb and reinstall it. So that was solved but the hassio update issue remains.

current 2.10 HASSOS Uptime = 5.5 days

The only Hassio Addons I use are DuckDNS, NGINX and Git PULL

It seems a bit more stable now, like it froze only once in the last 2 days after getting rid of MariaDB. But not sure what’s caused it to freeze last night though. But at least I have an email alert when it goes offline now though, from here:

It would be nice if HASSIO had some sort of activity monitor in order to see which addons are using up which resources.

While you can do this in SSH this isn’t a very user friendly solution, but if you know your way around Docker and SSH them look at your Docker Stats :slight_smile:

EDIT: Also try HassIO without any addons and see if you still get freezes