Having a hell of a time making my aqara sensors work with HA Yellow


I’m in the process of migrating my home assistant setup from a standalone RPi 4 running hassio off an SD card and using a Raspbee/deCONz to using a HA Yellow with the built-in zigbee module.

The old setup worked pretty well. Far from perfect, but functional.

With the new setup I’m having an awfully hard time consistently connecting the aqara sensors to the yellow.

Sometimes it finds things quickly and they work, sometimes it never finds them, sometimes it finds them, seems connected, but the sensors never report state changes.

Has anyone had success using this setup? Did you do anything in particular? I’ve considered maybe changing the batteries in my sensors? But I think most of them are pretty okay.

I’ve verified my 2.4GHz Wifi network shouldnt have any channel overlap (zigbee is on channel 20, WiFi is on channel 1). I do have some neighbors, but they’re super far away. There’s only one neighbor on channel 11, and a couple on 6, but their signals are all pretty weak. I don’t think it’s interference.

Distance from the Yellow doesn’t seem to matter much. I’ve relocated some of the sensors that were giving me issues closer and that didn’t seem to help.

I’ve seen other posts on here about just unpairing an repairing for hours on end until things work… and I’ve already tried that with a few sensors… I have like 20+ of the damn things and I really don’t want to spend 20+ minutes screwing around with each one.

Anyone have any thoughts? Tips? Anything I should try that I haven’t already?


Make sure that not getting EMF/EMI/RMI interference from any other sources (as Zigbee radios are extremely sensitive to EMF/EMI/RMI interference from all different types of sources, not just WiFi), and also be sure to first add few good mains-power Zigbee products that act as Zigbee Router devices (also known as Zigbee signal repeaters and Zigbee range extenders) before you pair any battery-powered Zigbee devices, read → https://www.home-assistant.io/integrations/zha#best-practices-to-avoid-pairingconnection-difficulties and I also highly recommend try to follow all the tips here before troubleshooting any further → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

If willing to live on the cutting-edge then could also try upgrading to a newer BETA-version of EmberZNet NCP firmware of the Zigbee Coordinator, but I would advise reporting the issue to get your debug logs analysed before doing so, see → https://www.home-assistant.io/integrations/zha#reporting-issues

Thanks for the reply.

One of the reasons I don’t think I have interferance is because this is a drop-in replacement for HA that was working fine with all these sensors. If I were having signal interferance wouldn’t one assume I would have been having it before?

I also live in the middle of nowhere and don’t have anything in the house that would cause such interferance. My nearest neighbors are 500+’ away.

Not even sure how I would test for that otherwise.

I’ll give the rest of your links a ready. Thanks again.

EMF/EMI/RMI interference primarily has an impact at close range, so think within 2 meters (or less).

Sources of EMF/EMI/RMI interference noise can be anything that is powered by electricity, including electric appliances, power-supplies as well as all cables/wires.

The most common EMF noise source I have seen are computers, monitors and computer peripherals, (especially USB 3.x), and different types of device chargers.

It is thus much more likely that it is a users own system that they run Home Assistant on (or external harddrive) that is the root cause, rather than their neighbours WiFi.