Having Issues With Sonoff MQTT Dongle

Hi, I am trying to get a new Sonoff Zigbee 3 USB Dongle Plus working in Home assistant on my raspberry pi.

I have followed a couple different YouTube tutorials, but I can’t seem to get the dongle connected.
The first one being Mark Watt Tech and the other being smart home junkies tutorial.

Below is the error from the log.

Zigbee2MQTT:error 2022-04-14 16:19:35: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-04-14 16:19:35: Failed to start zigbee
Zigbee2MQTT:error 2022-04-14 16:19:35: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2022-04-14 16:19:35: Exiting...
Zigbee2MQTT:error 2022-04-14 16:19:36: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:100:27)
    at start (/app/index.js:101:5)

If anyone could help, that would be great.

One of the error messages includes a URL leading to documentation for debugging the problem. Did none of the suggestions work?


All that really said was make sure the port was correct.

and make sure ZHA is disabled/removed

think I also saw somewhere to try using the full device ID rather than the device path e.g.


rather than:


your device id may differ but you find it in the same place (system/host/…/hardware)

haven’t tried this myself

I did try the device id using this guide and even added the port number like he did

I will have to double check that ZHA is disabled. I never enabled it or added it. Does it get enabled automatically after detecting the dongle?

Ok, adding the full device id and now I get this

Zigbee2MQTT:info  2022-04-14 22:46:58: Starting zigbee-herdsman (0.14.20)
Zigbee2MQTT:info  2022-04-14 22:46:59: zigbee-herdsman started (resumed)
Zigbee2MQTT:info  2022-04-14 22:46:59: Coordinator firmware version: '{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20220219,"transportrev":2},"type":"zStack3x0"}'
Zigbee2MQTT:info  2022-04-14 22:46:59: Currently 0 devices are joined:
Zigbee2MQTT:info  2022-04-14 22:46:59: Zigbee: disabling joining new devices.
Zigbee2MQTT:info  2022-04-14 22:46:59: Connecting to MQTT server at mqtt://
Zigbee2MQTT:error 2022-04-14 22:46:59: MQTT failed to connect: connect ECONNREFUSED
Zigbee2MQTT:error 2022-04-14 22:46:59: Exiting...
Zigbee2MQTT:info  2022-04-14 22:46:59: Stopping zigbee-herdsman...
Zigbee2MQTT:info  2022-04-14 22:47:09: Stopped zigbee-herdsman

Oh, Mosquitto wasn’t running.

Seems to be working now. Thanks.

I had tried so many combinations of users, that Mark Watt Tech had suggested to add, and other things I saw in videos.

I will mark the best answer.

Hello, I am having the exat same problem. @BadPlayer can you tell me what firm did you flash on the dongle and how to be sure that zha is disabled? I mean I have never used zha. I am trying to migrate from cc2531 to sonoff, but so far no luck.

When you plug in the sonoff dongle, ZHA automatically pops up in the integrations.

Just click the 3 dots in the bottom right of the integration and click disable on the “sonoff zigbee 3.0” integration.

Also, I used this method from Mark Watt Tech to flash the Sonoff dongle.