Having problem reaching HA after adding duckdns add-on

Installed duckdns add-on. started the service and checked the log to see that a certificate was given. Added the needed section to the conifguration.yaml file and checked for the configuration validity. After restarting home assistant can no longer log into the system. Used the https://domain-name.duckdns.org:8123/.

The error I am getting is :

This site can’t be reached xxxxxx.duckdns.org refused to connect. Try: Checking the connection Checking the proxy and the firewall ERR_CONNECTION_REFUSED(edited)

*[* 12:24 AM *]* 

How can I fix it?

Might be off base as it’s been a long day but you have to forward port 8123 in your router to your HA server instance and you have to specify your IP address with duckdns. Are you doing this?

The amount of incorrect configurations around this is really high.
Would be better if you could post this so it can be confirmed it has been done correctly.

Where did this message come from?
To my eyes it doesn’t look like a HA log.

I added the following text to the configuration.yaml file (changed here my domain name to xxxxx from security reasons):

   base_url: xxxxxxx.duckdns.org
   ssl_certificate: /ssl/fullchain.pem
   ssl_key: /ssl/privkey.pem

also I forwarded port 443 in the router (mapped to port 8123 internal), and the server has a fixed reserved IP address. again, when starting the duckdns add-on I see in the log that a certificate was granted. The error I am getting in from the browser that is being used to log remotely into HA using HTTPS

welp, seeing as base_url has been deprecated for months now, I reckon that’s your problem mate …

Remove that line and try again.

Thanks mate. Will give it a try now.

Removed that line and still get the same result. When I use that same URL to log in remotely without adding the port number at the end (":8123"), I am getting access to the router. I guess that shows that the dns mechanism is working properly. Somehow something with the certificate is conflicting with other things. Whats the recommendation to proceed from here?

I have also problems after base_url has been deprecated. Port 443 is locked from my isp, so i have 8123 to 8123. I cannot access xxxx.duckdns.org:8123 from home network. I cannot access localy from Android companion app, because is https. Google TTS doesn’t work. Complete mesh…

is there a way to check if a port is open from the subnet of th HA server? Lets say for example port 443

This doesn’t make a whole lot of sense. You can place in any IP/domain and port.

Just go to https://ip_address:8123 (notice the “S”) if your certificates work, then TLS is enabled. You don’t need to use your DuckDNS domain-name exclusively.

I can reach HA either locally of remotely when using http (either by using duckdns url of ip address). When trying to use https I am getting the error :

This site can’t provide a secure connection

Really frustrating. When I use canyouseeme.org service to check whether ports 443 and 8123 are accessible I am getting that both go thru

I cannot access https://xxx.duckdns.org:8123 when I’m local (???) and on https://xxx.xxx.x.x:8123 I’m guessing there is a warning that the site is not secure, that the app cannot bypass. Maybe i will start using Nabu Casa. I don’t know…