Having some troubles adding an Aqara WXKG03LM (ZHA)


i’m having some issues trying to add 4 Aqara switches to my Zigbee devices.

I’m using ZHA and when i add a WXKG03LM it adds the device with only a battery entity

I tried readding the device several times but everytime is the same result.

I’m a beginner with HA (i’m going to migrate away from Homey) and i just need a few control switches for the WAF :wink:

Thanks in advance for any help/suggestions!

Thats normal you will not see the switches there.
If you make an automation over the automation editor you can use the switch there


well i’ll be…thanks!

i can see it in the automation;

now, for the bonus round…

i’m making my automations in NodeRed.
in NodeRed i need to use the entity_id property.

How could i use this switch in NodeRed?

(Thanks again for the pointer!)

did you fix it?
I have the same problem,and i don’t know how to fix it.
can you help me?

i switched to Zigbee2MQTT and everything works way better :slight_smile: