Having Trouble Adding Ecobee Integration

I have added Ecobee integrations in the past. Howver I am trying to add it back on a fresh install and now I am getting a “Error requesting PIN from ecobee; please verify API key is correct.” while trying to add the API back in.


I can not get an API key from ecobee, when I try to register as a developer, all you get is a login page for developers, no way to create a developer account, only a login. The standard user credentials for ecobee fail to login, you get an error message as email or password is incorrect. Click the forgot password field, server error, page isn’t loading…

How/when did you get an API key to use in the Ecobee integration?

Home Assistant auto discovered my Ecobee device, so I click configure, and it immediately prompts you to enter your API key, can’t proceed any further.

Turn your mfa off it it is on. Once you activate, turn it back on. TL,DR got you? It’s in the documentation :stuck_out_tongue:

Resolved some time back, but for the life of me, I don’t recall how I resolved it!!! :laughing:

It was a pain, but simple when I found the work around……damn, getting older sux, can’t remember sh1t!

Edit, ok, now I do remember, and yes, it was by turning of my mfa :laughing: (2FA, don’t you hate auto correct!) which allowed me to proceed. Seems like they should fix on their backend, but, hey, the workaround took care of the issue!

Did you ever figure this out? I’m having the same problem. I’m able to general an API key from ecobee, but when I use it to set up the Homeassistant integration, I get the error unable to get the API PIN.

MFA is turned off on ecobee, but I think that was only for the issue of not being able to generate an application with an API key. I have that, I just can’t seem to use it.

Same issue here. Any ideas?