Having trouble setting up a frontend development environment

Starting off at: Frontend development | Home Assistant Developer Docs

I immediately get ‘stuck’ on the first section. I forked the frontend repo on GitHub. However, cloning the repo in CLI like shown on the development page doesn’t work for me, most likely because I’m on Windows. I feel like this blogpost is written for a Linux machine.

When I issue the command git clone [email protected]:Timmiej93/HA_frontend.git (Timmiej93 being my GitHub and Git username, and HA_frontend being the name of the repo), I get the following reply:

[email protected]: Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I figured it wasn’t that big of a deal, since this can be done outside the CLI too, so I went on to setting up the dev environment: Set up Development Environment | Home Assistant Developer Docs

Docker, VSCode and Git are installed. I also forked the HA Core repo (Timmiej93/HA_core). Clicking open did indeed open VSCode, and after a while, the container is up and running.

So I went back to the Frontend dev webpage: Frontend development | Home Assistant Developer Docs

Now this is where the real issues start. Opening the configuration.yaml file is no problem of course, but what do I set the development_repo path to? I assume this is a path inside the container. Just for testing, I manually copied the frontend-dev folder into HA Core, and put development_repo: ./frontend-dev/. Before I did that, I also tried mounting like described below that, but again, no luck.

Then they go on about using the docker-build task. For that to work, I first had to install the Docker extension, which for some reason isn’t in the recommended extensions. With that installed I can run docker-build, but it says “No docker-build tasks found. Go back”.

So by now, I’m pretty stuck, but I still figured I’d continue to see if the rest made sense. Under the header “Installing Node.js”, I followed the linked readme for installing nvm. I tried this both on my local machine and inside the container. Both seem to install fine. However, nvm install doesn’t work on either of them. Both reply with “No .nvmrc file found”.

So yeah, safe to say: I’m stuck. I get that these instructions aren’t meant to be a hand-holding tutorial, but it feels like there’s a lot of info missing here. What am I doing wrong?

1 Like