Having trouble setting up Google Assistant


Installed it using hass.io app repository (great stuff)
made the json file and placed it in the right directory

than I have to open web ui and get a token
I get the token I paste the token and want to authenticate and this is the result

indent preformatted text by 4 spaces

500 Internal Server Error

The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
File “/usr/local/lib/python3.5/dist-packages/cherrypy/_cprequest.py”, line 670, in respond
response.body = self.handler()
File “/usr/local/lib/python3.5/dist-packages/cherrypy/lib/encoding.py”, line 221, in call
self.body = self.oldhandler(*args, **kwargs)
File “/usr/local/lib/python3.5/dist-packages/cherrypy/_cpdispatch.py”, line 60, in call
return self.callable(*self.args, **self.kwargs)
File “/hassio_oauth.py”, line 46, in token
self.oauth2.fetch_token(self.user_data[‘token_uri’], client_secret=self.user_data[‘client_secret’], code=token)
File “/usr/local/lib/python3.5/dist-packages/requests_oauthlib/oauth2_session.py”, line 244, in fetch_token
self._client.parse_request_body_response(r.text, scope=self.scope)
File “/usr/local/lib/python3.5/dist-packages/oauthlib/oauth2/rfc6749/clients/base.py”, line 409, in parse_request_body_response
self.token = parse_token_response(body, scope=scope)
File “/usr/local/lib/python3.5/dist-packages/oauthlib/oauth2/rfc6749/parameters.py”, line 376, in parse_token_response
File “/usr/local/lib/python3.5/dist-packages/oauthlib/oauth2/rfc6749/parameters.py”, line 383, in validate_token_parameters
raise_from_error(params.get(‘error’), params)
File “/usr/local/lib/python3.5/dist-packages/oauthlib/oauth2/rfc6749/errors.py”, line 325, in raise_from_error
raise cls(**kwargs)
oauthlib.oauth2.rfc6749.errors.InvalidGrantError: (invalid_grant)
Powered by CherryPy unknown
indent preformatted text by 4 spaces

Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

Could you post your options you setup ?

should look like this :

  "mic": "1,0",
  "speaker": "0,0",
  "client_secrets": "google_assistant.json"


Exactly, didn’t change a thing to that configuration,but that’s also not the problem. It’s the authenticating part that doesn’t work. You can go to that web ui thing just once after you installed, you can get a key, you fill in the key and than it goes to the error I copied.

“mic”: “0,0”,
“speaker”: “1,0”,
“client_secrets”: “google_assistant.json”


Have you actually tried it to see if it’s working anyway. Mine gave an error after putting the code in but actually works just fine, didn’t check what it was though so may have been something completely different.


I had this issue at first.

Try re-downloading the JSON you were given.


Select the correct project and replace the google_assistant.json in the \hassio\share folder


none of these tips work unfortunately
it just won’t authenticate, gives an error, always


the JSON is in the folder : \hassio\share ?



I have now received the same error mesage on 2 devices. the JSON is in the share folder, however I get

[Error] You need initialize GoogleAssistant with a client secret json!


Could you fix this problem. I get the exact same error.


no need for it anymore
use the cloud option and connect hassio in your GA, it’s available in the smart home section


Thanks for the hint, but I get the same error when trying to authenticate the Google Assistant Webserver Addon, so if you know how to fix it, it would still help.


Why are you using the addon? Just use the build-in integration. Hassio --> settings --> integrations. Connect to tthe cloud and connect hassio/google home in the home control section of google home. Works like a charm.


I do use this feature now, but I dont know what it is good for, cant see any diffrence. I would like to use the addon to broadcast messages like ‘Play music from spotify on my chromecast’ or ‘turn on my Smart-Life Plug’ to my google home, because I was not able to implement this directly (I can only implement the plug with IFTTT and via Scenes).