Home Assistant Community

Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f374a309a20>
#314

Not who you were asking, but not working for me.

  • Using same google account for the relay as I set up the Google Home
  • Not on DND
  • Broadcasting works from Google Home’s, from my phone by voice, and from my phone by typing “broadcast test”
  • No errors from the relay and it shows up in my activity OK, it just doesn’t play on my devices (see a few posts back for more details)

Guessing its on the Google end and not due to your relay, but open to suggestions.

0 Likes

#315

Okay, so in Google Actions I believe (or somewhere in there) you configure exactly what rights you give to that particular assistant you are creating. One of those is broadcast maybe?

You’re essentially creating a project for a new google assistant and telling it what you want that assistant to be able to do.

0 Likes

#316

So, try this:

Go to https://console.actions.google.com
Make sure you’re here using the same google account as your google home.

Create a new project.

In the possible options, select “device registration.” It says “enable google assistant for your hardware”.

Now just fill out some stuff for the model name, etc.

For “device type”, select “auto”.

For “spec traits,” just don’t select any. Leave them all unchecked.

Now, you can download this OAuth json file to use for my add-on.

Let me know if this solves your issue.

0 Likes

#317

OK will try tonight. This worked great until last week and stopped for no apparent reason.

0 Likes

#318

Also, once you do the above steps, try unplugging your google home and reconnecting it to power after 30 seconds.

0 Likes

#319

I uploaded google_assistant.json to share folder, I click Open Web UI insert Authentication-key and click connect. Then I get this 500 Internal Server Error: The server encountered an unexpected condition which prevented it from fulfilling the request. Followed by a huge error report.
Any Ideas?

0 Likes

#320

Accidentally authenticated with incorrect token. Now I cannot connect to port 9324 to enter correct token. Also cannot uninstall addon to reinstall and start over.

0 Likes

#321

No go. Same result. Authenticates OK, shows up in history, but no broadcast from my devices. Reboot all Google Homes as well.

0 Likes

#322

In your Google Home app, you should be able to view activity.

You can see mine above. What does yours look like?

0 Likes

#323

That’s what I was referring to as showing up in my history. Looked like that when it was actually broadcasting and looks the same now that its not.

Its just weird since I can type “broadcast blah blah blah” in my phone and it works fine. Has to be on the Google side. Maybe I’ll try using my wife’s account since she is registered on each device too.

1 Like

#324

@AndBobsYourUncle Thanks for your great addon!
Unfortunately it is not working for me after migrating to hassOS 1.7 (64bit RPi) and restoring a snapshot.
I can’t install your addon anymore, button colored red and nothing else seems to happen. I thought is was not installed because it is not listed directly within HA’s webinterface. But with the CLI it is still listed with: hassio ad list
But there I can’t do anything else then show it in the list. When I try to delete, update etc. the addon with the -name Google Assistant Webserver is not found ?? ;-(

Can you, please, help me (a noob) to get your addon working again? Any help/tip is appreciated.

0 Likes

#325

Yep same here. no go on latest HassIO

0 Likes

#326

Same problem here as well! Running 0.74

0 Likes

#327

Addon has not been working for me for a while now. It used to not work due to the google update/error that was fixed a few weeks back, worked a bit and then stopped again.

Today, I wanted to start from scratch, created a new json-file and wanted to uninstall and reinstall.

Problem 1: I cant uninstall the addon! After hitting uninstall and confirming I get sent back to the Hass.io Addon page and the GA Webserver is still there just greyed out/not running… Tried that several times, multiple hass.io restarts, cant uninstall.

Problem 2: When I start it now I get the following error in the log:

[Info] Install/Update service client_secrets file
Traceback (most recent call last):
  File "/hassio_gassistant.py", line 144, in <module>
    credentials.refresh(http_request)
  File "/usr/local/lib/python3.5/dist-packages/google/oauth2/credentials.py", line 136, in refresh
    self._client_secret))
  File "/usr/local/lib/python3.5/dist-packages/google/oauth2/_client.py", line 237, in refresh_grant
    response_data = _token_endpoint_request(request, token_uri, body)
  File "/usr/local/lib/python3.5/dist-packages/google/oauth2/_client.py", line 111, in _token_endpoint_request
    _handle_error_response(response_body)
  File "/usr/local/lib/python3.5/dist-packages/google/oauth2/_client.py", line 61, in _handle_error_response
    error_details, response_body)
google.auth.exceptions.RefreshError: ('deleted_client: The OAuth client was deleted.', '{\n  "error" : "deleted_client",\n  "error_description" : "The OAuth client was deleted."\n}')

I would guess that means it cannot find the json-file in my /share/ folder as the message never changed, even when i purposefully entered a wrong name for the json file. OR somehow it saved the old json-file and ignores the new one (i did delete the old client @ google and created a completely new one).

Help is appreciated. Any way to “hard uninstall” an addon?

Edit: Just tried uninstall via CLI, didn work either:

core-ssh:~# hassio addons uninstall -name fe49a976_google_assistant_webserver
Error decoding json invalid character '<' looking for beginning of value: <html><head><title>500 Internal Server Error</title></head><body><h1>500 Internal Server Error</h1>Server got itself in trouble</body></html>
0 Likes

#328

I had the same problem after transitioning from ResinOS-based hassio to Hassos. Several of the plugins weren’t working including Google Assistant Webserver. It wouldn’t let me uninstall either. The work-around for me was to make a partial snapshot that did not include the Google Assistant Webserver plugin and then do a fresh install and restore.

0 Likes

#329

Thank you, that worked (eventhough its an aweful lot of work for reinstalling an addon…)

After reinstall, atleast I dont get error messages in my log! The broadcast messages I am sending are showing unter “My activities” in Google Home, but the devices are not broadcasting for some reason :frowning:

0 Likes

#330

@AndBobsYourUncle, hoping you can give me some guidance on a special use-case for your webserver. Here’s the scenario:

I’ve a MS6126 switch device (https://www.jaycar.com.au/240v-mains-wi-fi-wireless-switch-module-with-app/p/MS6126) that has no Home Assistant Component, however it is supported by Google Assistant (https://assistant.google.com/services/a/uid/00000040393e4c1c?hl=en-US)

Using your Google Assistant Webserver I can create a template switch in Home Assistant which will turn on or off the MS6126 by issuing the command “turn on XX light” and “turn off XX light”, but i’d also like for Home Assistant to be aware of the current status of the MS6126.

Using your “GAWS” addon is it possible to issue the command “is the XX light on” and parse the verbal response from Google Assistant so that Home Assistant can update the status of the switch? (i.e. update the template switch in Home Assistant UI so i can see remotely if the light is on or off).

Any advice would be appreciated!!! Thanks.

0 Likes

Is this wifi switch supported? ANKUOO / MS6126
#331

I discover every day some new awesome community add-on. I’ve migrate from a classic Rpi3 to hass.io today … and I will try this as soon as possible.

Just a question, why it need another add-on ? This feature could not be implemented in the normal Google Assistant add-on ?

Thanks for your work !

0 Likes

#332

@12-hak @DFilippo @NicoS

Are all of you using the 64 bit version? There are other addons besides this one that you may have problems with as well when using it. As there were no apparent advantages to using 64 (it was much slower for me in every way), I switched to the 32 bit version.

0 Likes

#333

I have the 32-bit version and can’t install the addon either.

0 Likes