HDMI_CEC with hassio


This seems to not work for me. I’ve been told libcec is installed in hassio, but adding hdmi_cec to the config file still brings up an error.

Any ideas?

Is there anyone that has been able to add hdmi cec to hassio?

Hi. I have a problem with hcmi_cec + Hass.io, too. First I had an error message that the OSD name was too long. I could fix it with this config:

  osd_name: HASSIO

But then I got the warning that no adapter was found. I created an issue on github for that. If you have the same problem you could add a comment there:

If you don’t have the same problem like me, what’s your error message?

HDMI_CEC with hassio bring up an error

2017-08-15 17:13:13 ERROR (MainThread) [homeassistant.setup] Error during setup of component hdmi_cec
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/setup.py”, line 194, in _async_setup_component
component.setup, hass, processed_config)
File “/usr/lib/python3.6/asyncio/futures.py”, line 331, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.6/asyncio/tasks.py”, line 244, in _wakeup
File “/usr/lib/python3.6/asyncio/futures.py”, line 244, in result
raise self._exception
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/hdmi_cec.py”, line 184, in setup
adapter = CecAdapter(name=display_name, activate_source=False)
File “/usr/lib/python3.6/site-packages/pycec/cec.py”, line 24, in init
self._cecconfig.strDeviceName = name[:13]
File “/usr/lib/python3.6/site-packages/cec/init.py”, line 1042, in
setattr = lambda self, name, value: _swig_setattr(self, libcec_configuration, name, value)
File “/usr/lib/python3.6/site-packages/cec/init.py”, line 74, in _swig_setattr
return _swig_setattr_nondynamic(self, class_type, name, value, 0)
File “/usr/lib/python3.6/site-packages/cec/init.py”, line 63, in _swig_setattr_nondynamic
return method(self, value)

When I type this :curl -d ‘{“devices”: [“vchiq”]}’ http://hassio/homeassistant/options
return: {“result”: “ok”, “data”: {}}core-ssh:~#

Try to use a shorter OSD name. See my config above.

Same issue here.
I got the same error and use the actual Hassio.


Not initialized. Waiting for init.

Every time i try to scan via the HDMI Cec Scan Addon i get following error:

    starting version 3.2.2
    opening a connection to the CEC adapter...
    ERROR: [ 108]	RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
    ERROR: [ 108]	Open - vc_cec could not be initialised
    ERROR: [ 108]	could not open a connection (try 1)``

Anybody got an solution for me?

Thanks in advance!

I get the same! Mine hasn’t worked for several versions of hass.io. I reported it on the discord to the dev who made the scanner plugin for hass.io but he never responded.

I also reported this on GitHub and seen that we are not the only ones who get that error. Maybe somebody know an workaround for this problem?

I can’t say for sure, but I think it has to do with the permissions of the HASSIO container. When I go into the root (I’m not a linux person, normally, so please excuse me using incorrect terminology), I can send the command for cec-client on and standby. That said, I tried, and failed many times, to make a shell command to have root do it