Headless KVM install is not working

I’m trying to install Haos on my Ubuntu 22.10 according to the official install guide.

Using this command:
virt-install --name hass --description “Home Assistant OS” --os-variant=generic --ram=2048 --vcpus=2 --disk path=/home/xxxx/VMs/haos_ova-9.5.qcow2,bus=sata --graphics none --boot uefi

Gives me this output:
An install method must be specified
(–location URL, --cdrom CD/ISO, --pxe, --import, --boot hd|cdrom|…)

Any suggestions?

I was able to install by putting “–import” at the end. So far all is good but I can’t access HA on any address. I’m on but it seems like HA is on Unless anyone has a solution tip, I will have to waste a lot of time searching about how to set up KVM and network.

1 Like

Here is a guide you might find helpful…

Not so helpful right now since I was able to fuck up the network on headless linux when trying to fix my bridge problem. Hahaha In fact, Now starting from scratch again. I will try that -HowTo on my next attempt.

Of course that HowTo got stuck too during the installation process:

Error: --disk haos_ova-6.6.qcow2,format=qcow2,bus=virtio: Size must be specified for non existent volume ‘haos_ova-6.6.qcow2’

Running HA in docker was a pain in that ass but migrating to HAOS is not easy too. So far it seems like all install instructions are less accurate, that seems to go for both HAOS and docker install.

Did you download version 6.6 as it seems you specified in your virt-install command?

The error Size must be specified for non existent volume ‘haos_ova-6.6.qcow2’ seems (to me, at least) to say that this file (haos_ova-6.6.qcow2) does not exist.

That’s also a quite old image at this point, so perhaps you need to change that version number in your command (see the first paragraph under 3 - Install HassOS VM detailing this)

Of course, that was my silly mistake. :roll_eyes: Sadly I forgot to go back and update my post.

Your --import got me unstuck. Relating to your problem (that I guess you solved since then) the setup command again lack a parameter to select a network adapter, so it’ll work (you’ll see hass on your home network) only if your default network in libvirt is of type bridged with a bridge attached to your ethernet adapter.
I had one set up as a different network and had to remove the default network adapter and add a new one form this network to be able to access it.