Heatmiser Neo-hub support, ugly and work in progress

I don’t think I populate the operation_mode from memory, I’ll see if I get 10 minutes to have a fiddle with that over the next week.

Should have a working version of the code that supports “current_operation” (after my various mistakes). Grab the latest version from github and give it a go.

Happy to report that two of my three Neostat-V2 are reporting their states across Idle and Heat

The third one is reporting Idle and 0 degrees as it’s currently disconnected after an unfortunate incident with a drill and the floor.

Thank you for the code and the super-fast update!

when i put one room thermostat in away mode, all other 11 thermostats also go in away mode. Can you make a change so that only the thermostat involved is affected?

Hi, unfortunately I’m getting another config error with the update to 0.88.

Your configuration contains extra keys that the platform does not support (but were silently accepted before 0.88). Please find and remove the following.This will become a breaking change. - [debug]

If you have any ideas which the ‘extra keys’ would be that would be great! Thanks.


If you knock out the

debug: True

From your config as part of:

  platform: heatmiserneo
  host: XXX.XXX.X.XX
  port: 4242
  debug: True

That should solve the issue, apologies it’s legacy stuff. Someones opened a request for documentation on the github page. I’ll try and get to it when I can.

thanks. really appreciate your continued work on it!

Hi, since i updated to the latest HA version (89.1) the thermostats no longer work and I get a message: Platform not found: climate.heatmiserneo. I had the same with Melcloud for Mitsubishi airco’s. An update was posted which solved the problem. Could you please check whether the update caused the problem? By the way the “away” setting still moves all the thermostats to away instead of the one in question. And setting it back doesn’t work, I have to do that through the App. Thanks for the good work on the Heatmiserneo!

1 Like

Hi @Trouble-51,

I’ve just fixed this, I’ll push up some patches later this evening.

Probably best if you raise these sort of things via issues in GitHub as I’m more likely to see them.

Thanks for the bug report on the away mode. I’m due to get me second thermostat today so I’ll actually be able to do some testing to figure that one out, although I wonder if this isn’t be Heatmiser’s design.

1 Like

Patches live on GitHub along with some other notes around docs etc.

1 Like

@MindrustUK Thanks for the update this is now working.

Thanks a lot, its working again!

When I try this it doesnt work :frowning: - I am pretty sure I have followed the instructions correctly but when I try and check my configuration validation the circle just sins and spins and spins.

If I comment out the lines in my config file it passes straight away.

For Info the lines are


  • platform: heatmiserneo
    port: 4242

Does anyone have any ideas? Would be very greatful!!!

I am complete idiot! Ignore me :slight_smile: resolved!

It looks like the latest HA version 0.92.0 has broken this again ?

Would it be due to the way Home Assistant is handling custom components in 0.92? There was a warning in v0.91

Added a quick and dirty manifest file. I’ll try and make something nice when I’m back home again. Find it in the usual place.

1 Like

Hi everyone,

I have this integration working and am working on an automation which should put one specific thermostat into Frost or Away mode if a door is opened. I’m using NodeRed for my automations, and can see all the Entities for both the Heatmiser Stats, and the door sensors. I have the flow built up to the point of needing to call the specific thermostat, I’m just struggling with the right JSON to pass the frost or away API call.

Has anyone worked on this and can steer me in the right direction?

Hello MindrustUK. Thank you very much for this component. Which I have working now.

  1. As a complete Raspberry Pi newbie I have failed to get either SSH or Samba working so I went for a more novel approach of using the Hass.io Configurator Execute Shell command functionality to create the directory structures and empty files. Then I copy-pasted the text content from files on my PC to get the .py and .json required in place.
    OK, so now you’ve stopped laughing…
  2. I have three types of neo-stats in my system: a) Standard neo-stats for my wet underfloor heating, b) E neo-stats for electric underfloor heating with temperature probes, and c) HW neo-stats that are on/off devices that are used to control timer for my gas boiler and timing for electric towel rails. The a) and b) ones look good but the on/off ones’ tiles need a bit of work to be useful.

I’ve lost the ‘off’ and ‘heat’ updates again.

I haven’t changed anything other than updating HASSIO.

If I try to change the state from Off to Heat I get a ‘failed to call service climate/set_hvac_mode’ message.

If I try to change the state from Heat to Off I get no message.

If I change the temperature in HASSIO it does change on the thermostat.