Heiman HS1SA-Z zwave smoke detector configuration not showing up


I started using zwave-JS and the zwave-js addon in Home Assistant for the Heiman HS1SA-Z zwave smoke detector.

While the device is detected, the configuration not showing up uder ’ configure device’ is not showing up.

The device is on this list on git hub (📢 Announcement: About supporting new device configuration files · Issue #1600 · zwave-js/node-zwave-js · GitHub), which makes me assume it has been imported but without the needed functions.

Can someone point me to the right way to get this device verified, or is there some way I can provide information needed to add the relevant functionality to the database?



Do you have a manual that shows configuration parameters? According to the Z-Wave Alliance Database, none of the versions of the HS1SA-Z it contains have any configuration parameters. The OpenHAB database does not list any configuration parameters either.

Mmm, I would have to look for that. I bought them like 2 years ago. I was under the impression that I used to set the wake interval time (using openzwave -HA integration at the time if I remember correctly). But I am now starting to doubt what exactly I did at the time.

The reason I wanted to change the wakeup interval is that it shows weird battery status ( one is 100%, another 0% but still working), and that after two years. But they have been ‘unconnected’ / standalone for the past year or so.

But if somehow indeed officially there are no configuration options, then either my recollection was wrong or somehow there was a field that I used that didnt do anything. ( I will look for the guide, but if I cant find it I will just assume I am mistaken here).

Thanks so far, if I find it (or any other useful reference) I will come back on this!

The Wake Up CC is listed as a supported Command Class for that device, so your memory is probably correct.

The HA Device Configuration for Z-Wave JS devices currently only shows Configuration parameters (Configuration CC). The Wake Up Interval is not a Configuration Parameter so it doesn’t show up. HA does not support setting this in the UI yet (zwavejs2mqtt does). It was indeed available in the legacy zwave control panel UI.

Besides switching to zwavejs2mqtt, for now you can set the interval using this service call from the Dev Tools: Open your Home Assistant instance and show your service developer tools.

service: zwave_js.set_value
  command_class: '132'
  property: wakeUpInterval
  value: 86400

Switch to YAML mode, copy and paste that YAML, then switch back to UI mode. You can than select the device and click CALL SERVICE to execute it. Change 86,400 seconds (1 day) to the value you want.

You’ll also need to manually wake up the device for it to be applied, or wait for it to accept the setting the next time it wakes up.

If you go to the Device page, and click the Download Diagnostics button (moved to the ... menu in 2022.6) you’ll get a json file with all the values. It will list the wakeUpInterval value and show the current setting as well as the allowed min and max values

Thanks a lot, that worked!
I was able to update the interval and verify that it is indeed updated on the device by looking at the diagnostics file!

Also good to know that indeed I remembered correctly, i really started to wonder :slight_smile: