Help a newb out please - custom component

I’m trying to install this component but I’m having absolutely no luck. I don’t really know what I’m doing, I’ve tried reading around the subject but I’m not really getting anywhere, and the instructions on the github page aren’t particularly helpful to someone who doesn’t know Home Assistant very well. I do know RPis reasonably well but I’m a bit lost with the file structure on hassio.

I’ve managed to SSH in (though I get the feeling this isn’t how it’s done) but I don’t really know where to find the folder I need. I’ve also managed to connect via FTP, but only an empty “share” folder appeared once I’d connected, so I’m obviously doing something wrong.

I think I can probably figure it out once I work out how to actually access the folders I need to be looking in…

Hassio’s config area is in /config.

Your custom component goes in a sub-directory of /config, ie /config/custom_components/media_player.


I know, i got as far as that, but I can’t find that on my FTP connection - like I say, the only folder was the share folder. So I’m at a loss as to how I go about actually accessing the directory.

I’ve managed to get to the directory through SSH but I don’t really know how to download the files through that so I was hoping I’d be able to get in over FTP.

I don’t have hassio running at present. Is git available?

Or scp/winscp from your PC?

You should setup the addon configurator or the IDE so you can easily access your backend files and upload new ones similar to using ftp.

Unsure on how to set up the addon configurator to give me access to the backend so I tried going down the IDE route and it just says it refused to connect when I tried to go onto the web UI or through samba.

I’m probably missing something very simple here I know, so sorry if I’m being a bit of an idiot…

@nickrout, I tried the winscp idea. Think I’m in now, thank you! Will see how far along I get with this now… :laughing:

Okay now for my next newb question… I have the files in place, but I don’t see anything for the component in either the add ons or the components area. Any idea what I’m missing? I’ve edited the config file as it said to and I’ve dropped in the file but still nothing. :frowning:

Hard to say without seeing what you put in your configuration.yaml file or you telling us what is in your log.

Did you restart home assistant?

Yes, I did, but then it wouldn’t come back on for some reason… so I’ve reinstalled hassio and I’m gonna give it another shot in the morning.

Okay I gave it one more go before bed, I’ve just tried checking my config and I’ve got this:

I realise this is probably something basic I’ve gotten wrong but is there anything obvious that jumps out from this? the instructions aren’t particularly clear to me…

Right, I’ve gotten a little further tonight, I made a boo boo adding the mediaplayer bit to my config.

I’m now left with this -

What do I need to show to figure out where I’m going wrong?

Looks like you haven’t configured any tivos or channels. The docs in the link you put in your first post shows how.

I thought I had but evidently I’ve done it incorrectly. Am I right in thinking that I need to make the configuration file look like the example.yaml?

Please post your config here. Note the instructions at the top of the page.

I’ve just realised. I copied over the text from the guy’s file. I forgot to change the TIVO name/code thing. My config has now returned as valid! :slight_smile:

I knew it would be something ridiculous… thank you for your help and time, anyway.

Glad it is coming right, pleased to help.

Okay one final question… I’ve made everything show up on my HA overview, Alexa has picked up what I’ve set up, but… well, nothing happens when I turn on the ‘switch’ it set up on HA. I know it’s connected as I can see the TV screen in the little card that comes up on the overview, but that’s about it.

Will this be reflected in the config or will it be somewhere else? just so I know what to post if anyone may be able to help.