Help accessing host ssh server on hassio

Hi everyone,

I’m struggling to regain access to host ssh server on hassio.

I had it configured in the past, and it suddenly stopped working, I suspect with some update of the core system.

Now I’m dedicating time to regain access but I seem to be unsuccessful in doing so.

So far I’ve tried to:

  • Import files from Supervisor > System > Host System, from a USB key called labelled CONFIG that holds just the authorized_keys files with my public key in it.
  • Manually editing the /root/.ssh/authorized_keys file on the hassio overlay partition, mounting the SD directly on my system

None of the activities worked and I’m out of ideas. I’ve already checked the permissions on both /root/.ssh and /root/.ssh/authorized keys and they are as expected

What else should I check? Or is there a way to reinitialize this? Maybe if I manually delete files and folder and then force a new import?

thank you

Having the same problem. Did you ever resolve this?