HELP! Accounts couldn't be linked Your Alexa-App needs an update

Hello community,

first of all I’d like to mention, that I am german but try to post my topic in englisch, as it semms to be usual and wanted here. So please pardon me, when my english is bad, I hope you will understand my writing.

I am quite new to HA, just installed it on an NUC7i5 a week ago, installed some add ons like Philips TV, File Explorer, HACS and things like that since then. Also installed the SkyConnect stick on my NUC. Everything went quite normal using several videos mostly from simon42 on youtube and I did nothing special. Everything worked fine so far.

Now I tried to set up the speech assistant’s also following a video named " Alexa & Home Assistant: Sprachsteuerung Deluxe! (ALLE Möglichkeiten)" from simon42, joined the HA cloud by a Nabu-Casa-Acount as explained there and am now trying to activate the “home assistant” skill in the Alexa-App on my mobile as the next step from the video.

But at that point my frustration began to increase cause that didn’t work like explained by simon42. I entered my Nabu Casa login data as requested by the alexa app and got an error message, that says: “Acounts couldn’t be linked Your Alexa-App needs an update” (as I am german, I got it in german and translated it here - hopefully correct enough). I then spent hours trying to get information about that problem using google search and searching the community here.

Seems, that it could relate to the authentification, for which, as the internet says, the access by port 443 is needed. Don’t know if that is really the problem, especially cause the found descriptions are already from months to years ago, and the used video from simon42 was posted to youtube on 1. april 2024. So he must have had already known about that an would have mentioned prerequisites for activating the skill, I think.

Trying to follow the port issue, I changed the port of my HA installation to 443 in the configuration.yaml, which works fine locally in my home, but did not chage the failure when trying to activate the home assistant skill in the alexa-App. I also activated the 2 phase authorization in my amazon account (once by using MS authentificator, once by getting the access code per text message on my phone), cause I thought/read, that it would be necessary. Some information from the internet pointed to port configration/redirecting of the router to redirect calls from outside of my local net to HA for the authentification calls by the skill activation.

I mostly could not really understand these descriptions, as my knowladge is minimal in these subjects. I gave up at 3 AM and hope, that someone here can help me as a I am not that deep into the technical details. I already read some topics here from which I often understand not the half of it.

Can someone help??

Many thanks in advance

I’m having the same problem, I opened an issue on github:

I also tried many things, all to no avail…
I am in Europe, but it always uses the pitangui URL, no matter if I set English (UK) or (US) in the Alexa app. So I am using an US lambda function and skill (I tried both). Reinstalling Alexa didn’t help. My phone is Huawei P30 Pro.

I think this is an Alexa issue as I have a similar problem, although, I disabled/re-enabled another Skill and am getting the same message. Not sure what’s going on, but I would recommend not disabling any Alexa skills at this time - something’s not right.

Hi, I’ve had this issue for the last 3 days and I’ve found a fix, so I’ve created an account on here specifically to share.

I was using Android 11 on my phone and was getting the same error messages as above. I didn’t have any notified pending system updates for my phone, but I went into my phones settings > biometrics & security > security update, and it stated downloading a security/software update.

My phone now shows as Android 12. I uninstalled Alexa App, then reinstalled and tried linking again, and it worked!

The post above about the Alexa App updating something security based got me thinking, and helped me fix the issue. So I wanted to share my fix. Hope it works for others :blush:

I followed #115863 on GitHub, and there mrbrdo reported:

I opened a ticket with Amazon, and found a solution for me. I had to find the app settings in Android settings (under Apps), and “Turn on ‘Open Supported Link’ if turned off.”. In my case it was “Ask every time”, but I changed it to “Always open”, and now it works. Or maybe they also changed something in my account.

This worked for me too, hope it help’s here too

1 Like

I’m trying this on an iPhone (with all the latest updates and a newly downloaded app) and I get this message too.

I’m using the Home assistant cloud.

I’m having the same issue on iPhone – fortunately I’ve got an Android too and it worked to link things. So it does indeed seem to be an iPhone Alexa app issue from my experience.

Brilliant! This worked for me too :blush:
Thanks buddy

So I’ve been frustrated by this post and everything because less tech savvy people definitely will struggle so I’ve got a step by step guide here on how I got mine working with Android version 13 in may 2024
I’m on a Nokia XR21 ( odd I know )

Open settings
Goto apps
Select default apps ( will usually be at the bottom of the list doesn’t actually look like a app it’s a tab )

Select opening links ( again at the bottom )
Select Amazon Alexa
Make sure open links is on
ADD the links you want to trust. I’m not 100% on which ones are needed but I added ALL the Alexa skill ones and Layla which is the most important I imagine.

Ps I’m not going to test or refine this more but I imagine you don’t need alllll the other sites such as just the country your in and Layla.

Hope this helps :melting_face::smiling_face:

1 Like

Android user here so basically you just need to enable the servers required to link smart products, that alexa will try to open

  1. Settings
  2. Apps
  3. Choose Default Apps
  4. Opening Links
    Find → Amazon Alexa
    5. Enable “Open supported links”
    Open “Supported web addresses”
    6. Enable " country)
    7. Enable "
1 Like