Help adding Zwave Devices

I’ve finally got my Silicon Labs UZB-7 updated to the latest firmware and connected it to my HA USB Hub

I’ve installed Zwave JS addon, and it has successfully detected my controller (I let it generate all it’s own keys etc)

Everything looks good in the Network page

However, I have now tried adding two different devices - TKB Plug (instructions) and a NeoCoolcam Motion sensor, and neither seem to connect. Both are plugged in / held right next to the stick so distance is not at fault

I have followed the instructions, reset them both (as far as I am able to tell - at least in so far as they are no longer controllable by the old hub) yet entering them into pairing mode seems to do nothing :confused:

How can I work out what is going on and how to repair?

EDIT: Just found the log page and set to debug:

Log Level changed to: Debug
2022-08-24T12:03:12.122Z CNTRLR   Starting inclusion process with strategy Default...
2022-08-24T12:03:12.149Z SERIAL » 0x0105004XXXXXXX                                                     (7 bytes)
2022-08-24T12:03:12.157Z DRIVER » [REQ] [AddNodeToNetwork]
                                    node type:    Any
                                    high power:   true
                                    network wide: true
                                    callback id:  17
2022-08-24T12:03:12.165Z SERIAL « [ACK]                                                                   (0x06)
2022-08-24T12:03:12.173Z SERIAL « 0x0107004a110YYYYYYY                                                 (9 bytes)
2022-08-24T12:03:12.176Z SERIAL » [ACK]                                                                   (0x06)
2022-08-24T12:03:12.180Z DRIVER « [REQ] [AddNodeToNetwork]
                                    status:      Ready
                                    callback id: 17
2022-08-24T12:03:12.204Z CNTRLR   The controller is now ready to add nodes

Did you also install the zwave js integration?


Yup (I didn’t think you can actually add a device without that, no? Either way I have it :slight_smile: )

Just for a bit more clarity, I’m adding via this:

and then this

But nothing is found :frowning:

Okay, so I’ve worked out what it was though a bit of trial and error…
The controller was set to US RF frequency (despite the EU firmware being flashed)

I’m not sure whether this was the right way to do it, but I discovered this through going through the process of using ZwaveJS2MQTT and getting that set up and then realising that it showed US. Changing that the EU and suddenly my devices are detected.

Now… question… should I continue to use ZwaveJS2MQTT or should I remove that and go back to using ZwaveJS on it’s own?
I have noticed that in the current setup the devices I’ve added don’t seem to be revealed to Home Assistant or my Mosquito broker (probably missed something in setup), but I think I read that best to just use ZwaveJS directly now anyway?

I’d stick with zwavejs2mqtt, why revert to something with less functionality.

1 Like

Well at the moment it has less functionality as I haven’t worked out how to get my devices revealed to HA!

Edit: I think it’s because I got an error that port 3000 was in use so I changed to 3001, but not sure… I think I might strip it back and start again!