Help - All addon with Ingress: 401 Unauthorized

Could you please share where this setting is? I have the same issue with Home Panel.
I tried using edge and it “worked” for a moment… but when I logged in to Home assistant got the same 401 error

Can confirm this too, clearing cache on Chrome does the work.

I just ran into this issue with Firefox. Everything working fine then all of a sudden 401s on any ingress addon. WARNING (MainThread) [supervisor.api.ingress] No valid ingress session None in the supervisor log.

Tried clearing cache, all site data, close, reopen etc. Didn’t work. Started looking through the settings. I changed the following from Strict to Standard and now we’re all good in the hood. I had not changed this setting previously so I don’t know what gives, but it did fix my issue.

Just an FYI if anyone else runs into this issue.

15 Likes

Thanks. You probably just saved me hours of time.

Edit:

Here’s a way to disable protection for a specific URL:

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop?as=u&utm_source=inproduct#w_what-to-do-if-a-site-seems-broken

Edit 2:

Just to see if I could reproduce the original issue, I recently tried turning Enhanced Tracking Protection back on. When I do this, Ingress and the add-ons still work, although I don’t I don’t know why.

9 Likes

Life Saver You :wink:
Thanks :star_struck:

1 Like

Saw the exact same thing on Firefox 90.0.2 (64-bit) on Windows: Ingress was just blank and I got a 401-response. I could not see ingress addons when accessing Home assistant on my LAN through the mDNS-address (http://homeassistant.local:8123). However, ingress worked when accessing the HA through HTTPS (https://example.duckdns.org), as well as when I used the LAN-IP directly (http://192.168.0.X:8123).

I struggled for hours. In the end, it was sufficient for me to remove the cookie called ingress_session. Thank you for the help!

This worked for me! Thank you! I’ve been researching this for a couple of weeks now and your solution was so simple. I ended up reenabling to Strict and the add-ons’ pages loaded perfectly fine still.

1 Like

jazzyisj

Solution worked for me as well. Thank you very much for posting.

1 Like

There’s an official alert for this issue now

2 Likes

I had the same error. After reading this post I thout that the cookies of home assistant were giving the problems. I deleted these cookies, and now it works like a charm

Cross posting from Discord to here:

Seems like I figured it out (for my situation.) Would be good to document it somewhere, let me know if that’s wanted, and I will.

In short the issue is that FF only allows cookies from the originating server. This can be changed by the parameter “Network.cookie.cookieBehavior” under “about:config”. Set it to 0 to allow all cookies and ingress should now work after a page refresh. Network.cookie.cookieBehavior - MozillaZine Knowledge Base

  1. in chrome open developers tools
  2. open Application TAB
  3. storage
  4. Clear site data
3 Likes

Thank you very much - for me this saved my day!

For me, clearing site data was not enough; I had to use my phone to clear all other sessions (clicking on your account name in the side bar then scrolling down). After logging in again, the addons work again.

I had the same problem. Go to sites settings and clear all data, that worked for me.