Help - All addon with Ingress: 401 Unauthorized

Hi, I have a problem, no addon with ingress works, the error 401 comes out, and this appears on the system log:

19-05-19 08:56:41 WARNING (MainThread) [hassio.api.ingress] No valid ingress session None

All other addon works!!!

Update, with Chrome (already clean cache), addon with ingress give me the error 401, with Edge working correctly :face_with_raised_eyebrow:

Hello, maybe this hint will help:
I just found, that in firefox some settings prohibit ingress to work correctly.
I’m investigating which one, will post the results when I found out.

Thanks, anyway I solved it, the first time I only cleaned Chrome’s cache, now I have completely uninstalled the browser, cleaned from all residuals and now all addons work regularly !!!

Same issue here, with Firefox.

I would very much like to understand how to get a consistent behavior. I have one home PC where ingress addons will return 401 unauthorized on chrome but work ok with Firefox. And another home PC where the addons work perfectly with Chrome.

I solved it in this way: clean the chrome cache, uninstalled chrome, reinstalled and now no more error

I share my experience : same problem after restoring a backup on other hardware.
Clearing navigator cache or changing navigator doesn’t change anything : the Supervisor tab is displayed once out of two times, many WARNING (MainThread) [hassio.api.ingress] No valid ingress session in logs (when I arrive to display these logs)

I finally restore with these settings :

And no problem anymore. May be the problem comes from the SSL folder ?
Anyway may be this screenshot can help to diagnose if you have this problem.

I am seeing this problem now in a Raspberry Pi Chromium browser.

And only that. And clearing the browser cache does not help. Installed Firefox on same machine and it works. Using Chromium on different machine. No problem.

Something has been saved somewhere that blocks ingress and only ingress. I can see rest of Home Assistant. Only the ingress Addons fail with the 401.

I removed my Chromium browser from the Raspi. Cleared our all setting files. Added it again. Same problem. There is one detail. I connect through a Wireguard tunnel. It worked just a few days ago. HA was not updated in that period. I wonder what changed??! Where are the files stored in HA? All in .storage/auth? Or other places?

I have been tearing my hair out over this. I have tried three different browsers, clearing cache, shutting down HTTPS everywhere, shutting down uBlock Origin, reinstalling browsers, sacrificing goats, etc. I am ready to throw my machine in the fire, and setup my firewall to block anything that every includes the phrase “home assistant” in it.

I understand your frustration

My symptom is more subtle. Everything works except…

One one specific Raspberry pi, running Chromium, using the http url to a 192.168 IP I get the 401. I first thought it was Wireguard as I used it remote. I brought it home and turned off Wireguard. It is itself on same subnet as my Home Assistant machine. And I still get the 401

I do not the 401 on HA in general. Only when I try to access Ingress based addons via the left bar.

It works in Firefox on same Raspberry Pi

It works if I use the URL inclusing “ingress”

It works if I use my fully qualified external domain name via my hairpin router and a reverse proxy that adds the ssl layer so I use https.

It only fails on one machine, only in Chromium, only with http via IP, only with links in left bar.

I have 5 other computers and two ipads and an iphone. It works on all of them.

I deleted Chromium from the Raspberry. I deleted all the cache and cookie files for the account. And installed it again. And still same shit.

Where the heck can Chromium hide some setting that triggers this fault? Why does the fault occur? I doubt it can be anything on the HA side because I get a new session cookie when I login again with the fresh browser.

I can probably just wipe my Raspberry and install a fresh OS on it. I have nothing special on it. But why does it happen? And it seems more important for @jds who has same symptom but much more severe.

I’ve got the same problem except it appears to only be visual studio code. I can fix it by uninstalling and reinstalling the addon but after I close the tab and reopen it I’m back to 401 unauthorized.

Last (?) EDIT: I figured out that the problem for me is that I was using HA in Frames as part of Organizr. So, when using the ingress side tabs, it was essentially a frame within a frame. This had worked before, and I had stopped giving it any thought. However, if I just use HA as its own tab in the browser, it now works fine. I should have found that earlier.

For me it is every single browser and every single addon that uses ingress.
It would be helpful if there were some error message in the logs.

Edit to mention that the android app does work.

I ran into this after I started trying to configure a second instance of HA running on a second network, but both accessed with the same hostname (homeassistant.local).

Clearing cache isn’t enough; I had to clear all site data (specifically cookies and/or database which is where the ingress authorizations are stored).

1 Like

Clearing cache isn’t enough; I had to clear all site data (specifically cookies and/or database which is where the ingress authorizations are stored).

Can confirm this worked for me.

I fixed my instance by restting the configuration for the add-on (Home Panel in my case) and upon logging in I changed the default homeassistant.local:8123 URL to the IP address of my HA docker and it resolved the issue. Looks like a DNS issue?

Can also confirm clearing cache and site data (in Firefox) worked for me.

Was also getting this same issue, many if not all addons were throwing 401: unauthorized errors. Clearing the ‘Site Cookies and Site Data’ in Firefox (hitting the padlock in the URL) resolved the problem.

Ingress suddenly stopped working, and I was getting an error 401 from all add-ons that have a web UI - such as file editor, terminal, etc. In my experience, after 40 years of IT, errors can usually be traced back to a change you mde, no matter how innocuous. I recalled changing a DNS pointer to a stealth pointer a week ago… basically i point my domain https://twosquarefeet.ca to https://twosquarefeet.duckdns.org. A standard URL pointer leaves my http header to contain twosquarefeet.duckdns.org and that appears in the address bar. Stealth mode hides the duckdns redirect, I assume by putting https://twosquarefeet.ca in the http header, and this appears in the address bar. I have an old domain with a standard (not stealth) URL pointer, and this works. So it appears that a stealth URL pointer on a domain breaks ingress. Sure enough, browsing directly to https://twosquarefeet.duckdns.org works too.