Help - Attempting UniFi Network Integration - Unable to Find Host

I’m having difficulty setting up the UniFi network integration. I followed the tutorial on “Everything Smart Home” (4 EASY Presence Detection Setups in Home Assistant - YouTube), setting up a second user with admin privileges, then when I attempt to enter the controller login credentials for the HA integration, I can’t seem to find the controller’s host information (see screenshot). I’m using UniFi controller version 7.0.25 on Windows. Older versions in the videos had a controller section in the settings with that information. On this version, I can’t find it. Does anyone have familiarity with this set up?

the host is the IP address of the machine running the controller software.

1 Like

I should have mentioned I did try that IP, which is the IP of my windows machine running the controller. So, I think it must either be the wrong login credentials (UN / PW) or the wrong Port. But I suspect the default 443 Port is probably not the problem. So, most likely bad credentials. Ubiquiti / UniFi has separate login credentials for the controller app and the online account - tried both of those. Also tried the Home Assistant login credentials. Any other thoughts?

Try port 7443 please.

1 Like

I’m pretty sure the port should be 443 (it used to be 8443 but that was changed a while back).

Did you create a user that has the correct permissions?

1 Like

Tried port 7443. No dice.

Created a separate view only user and am logging in with those credentials. Must have configured something incorrectly. Attached are a few screenshots:

  1. Shows the 2 UniFi accounts in the controller with the view only secondary account highlighted by a red box.
  2. Shows that I’m using the correct IP address, by confirming in cmd line with ipconfig.
  3. Shows the entered login credentials in HA.

Finally found the solution, in case anyone else runs into this problem. Spent hours, when all it came down to was a quick google search indicating the correct port is “8443”. Changed it and it worked.

I also face an issue with login to “Unifi Network” integration. I am just not able to login.
I switched port from 443 to 8443.

Host: (IPv4 of Home Assistant)
Username: Neavcen (Unifi Controller Login)
Password: *** (Unifi Controller Login)
Port: 8443

Error message with port 443: Failed to connect
Error message with port 8443: Invalid authentication.

But i am sure these are the correct credentials as I used them to login to Unifi Controller.

Thank you!