Help! Can I recover after no network on first boot?


#1

G’day All,

New user. Have spent about 12 hours on the forums today doing my best to read up before posting. I have managed to evolve from total newbie with no experience to the same with about +1 XP

I’m using a Pi Zero W with the Hass OS from the site. No matter how many times I create and edit a wpa_supplicant.conf in the root directory, my Pi wil not connect to Wifi on first boot.

Once I use the sudo nano /etc/wpa_supplicant/wpa_supplicant.conf command, the contents I’m presented are not the ones I placed in the root directory file. Easy, edit that and I’m up on wifi. The problem is, I’ve missed that first boot and am playing catchup. After hours and hours of searching I found my guardian angel in the form of user Ludeeus posting the following command;

sudo hassbian-config install homeassistant --force

Things are looking good and I get the message that everything is running and to go to the http://hassbian.local:8123 address but unfortunately, no luck. Cannot connect.

I have scrolled up and seen the following

Downloading/unpacking hassbian
Could not find any downloads that satisfy the requirement hassbian
Cleaning up…
No distributions at all found for hassbian
Storing debug log for failure in /home/homeassistant/.pip/pip.log

That doesn’t look great. I feel like I am playing a catch up game I’m never going to get on top of. Plus it looks like I’m missing some folders

[email protected]:~ $ cd /home/homeassistant/.homeassistant
-bash: cd: /home/homeassistant/.homeassistant: No such file or directory

My question is, does anyone know how to actually update these wifi settings before first boot (as the wpa supplicant file in root just doesn’t seem to replicate/bloody work at all) OR does anyone know a list of commands to install everything I missed on that first boot?

Thanks in advance to the community.


#2

If you find that the web page is not reachable after 30 minutes or so, check that you have files in /home/homeassistant/.homeassistant/ , if there are no files in this location then run the installer manually using this command: sudo systemctl start install_homeassistant.service .


#3

Thank you so much. I really appreciate the response.

I entered the command and hit enter, it just carried down to a new line and didn’t come up with anything. Is that normal? I tried again with the full stop at the end and got an error;

[email protected]:~ $ cd home/homeassistant/.homeassistant/
-bash: cd: home/homeassistant/.homeassistant/: No such file or directory
[email protected]:~ $ sudo systemctl start install_homeassistant.service
[email protected]:~ $ sudo systemctl start install_homeassistant.service.
Failed to start install_homeassistant.service..service: Unit install_homeassistant.service..service failed to load: No such file or directory.
[email protected]:~ $ 

Should I be including the full stop? Am I missing something? Thanks again, I have been stuck for days.