[Help] cant reach my Hassio after installing it on Virtualbox

Hey all,

new on HA.

just installed the HA on Virtualbox, i can see the installation done and see the following messages:
udevd[322] starting version 3.2.9
udevd[323] starting eudev- 3.2.9
udevd[181] starting version 3.2.9
udevd[182] starting eudev- 3.2.9

but i still cant reach the hassio UI:
i’ve tried hassio.local:8123 -> gets DNS_probe_finished_NXDOMAIN
i’ve tried [the laptop’s ip]:8123 ->gets connection refused

need your help guys


1 Like

Could you explain a bit more on the situation?
where is your virutalbox running which device
from where are you trying to reach HA.
do you use pi-hole?

How have you set up your network in vbox?

have you set the adapter type as above?
have you set “Promiscuous Mode: Allow All” ?


sorry for the lack of information.

im running the Virtualbox on an old laptop
this are my configuration:

VM network config

ipconfig laptop
laptop lan

ipconfig VM (from the cmd in the laptop)
box lan

Hi. I notice your IPv4 adresses are on a different range.
I assume your current working IP range is to
You have (laptop is correct)
you should not have for VM.
It should be 192.168.1.xxx And ofcourse, this last digit cannot be .1 :slight_smile:

The above is correct if you have NOT put a forwarding rule in place on your router

hope this helps.

i’ve changed the IP to one in the Subnet, but still cant reach it through web…
i’ve changed it to 192.168.56

when im searching for this device in my router, i cant see it, but in the laptop slot on the router it seems like it has static IP even though its DHCP and the VM is static.

any ideas?

just to check. You have changed the ip to 192.168.56.XX right? (where XX must be >1)

hmm. maybe I noticed something irrellevant.

this is my setup of vitrualbox. the line with the box, is the IP of the pc with virtualbox on it

im still a bit puzzled on what you are doing.
Do you have old laptop running windows? What OS?
And you have installed Virtualbox on this old laptop right?
And from that same laptop, are you trying to reach the virtual OS HA?
Or are you trying to reach it from another pc?
What are you typing to reach HA? port number etc… http or https?
Could you explain it a little bit more.

Dont forget HA needs time to do its first install. can take a while…

Maybe this helps.

Something doesn’t look right here. Why does this image say “Ethernet Adapter Virtualbox Host-only Network:”?

yes sir I tried as same as you mentioned above but unable to access by ip address or hassio.local:8123