Help connecting Hassio to network


i followed the Generic X86-64 guidelines to install Home Assistant on a laptop.

I went the host OS route. The laptop doesn’t have an ethernet connection but i used a USB-C dongle with an ethernet port.

Booting from the USB into Ubuntu worked fine. There i downloaded Balena Etcher and flashed the internal HD of the laptop. That all went fine too, rebooted the computer and it booted into Home Assistant. The only problem is that it doesn’t connect to the network.

It doesn’t seem like HA sees the ethernet connection, it only sees the internal wifi adapter.

I’m still on the computer that has HA installed on it. I can’t reach the Web UI yet.

Is there a way to make it see the ethernet connection or let me connect to the Wifi using the CLI?

This is only a test machine to play around with so it’s not a big deal if it’s not optimal. This is a test case to see how well this would run before i dedicate one of my Intel NUC’s to it

Any help would be appreciated

Some more info

If I use the command “ha network wlp1s0 scan” it does show me my available networks

The USB-C hub works. I have a USB keyboard plugged into it and that functions as expected.

You probably just need a driver for your network card.
We might need the name and model of your USB network card and the name of you linux distribution.

Thanks for your reply!

The USB-C hub i use is from AUKEY.

I’m not using a Linux distribution. I only used ubuntu-20.04.3 desktop on a USB stick to boot. Once there i downloaded Balena Etcher and flashed the internal HD of the laptop with the Home Assistant OS. So while in Ubuntu the network adapter just worked because i downloaded Etcher and the image i needed to flash the SSD with

After a reboot Home Assistant starts but i’m not getting an ip address

The home assistant is a Debian variant, so you need to look for Debian driver.

Maybe this link can be used too.
It’s about Ubuntu, but its not a package, but a built process, so it should work on many versions of Linux.

Did you ever find a solution to this issue? I’m about to set up in a configuration very similar to yours and want to make sure I know how to get connected to the network

I would suggest you go for a Supervised docker installation instead.
You then handle drivers and the like in the host system, which there will be plenty of support and help on.
I recommend the Debian Bullseye Linux then, since Alpine Linux, which HA use is close to this in commands and standard and the Rapsbian OSes are all based on Debian too.
You will eventually get into a Raspberry Pi too. :slight_smile:

Trust me I want to run it on a Pi but they’re impossible to buy right now. I used to run HA in a VM on windows and that actually did work mostly fine, but it would crash every few days and need a reboot, which is obviously not very desirable. I have a Surface Pro 1 from 2013 that is completely unused so I figured why the hell not try to run it natively on that via the x86 version, but realized I had no way of getting it connected to the network. So I bought a USB->Ethernet but then found this post detailing the fact that it’s not quite that simple and so now I’m unsure how to proceed if it won’t work natively and will need some finagling. I’m not super well versed in this stuff. A very basic user so most of what you just suggested went way over my head haha

Install Debian Bullseye on it.
This should be just downloading it to an USB stick and follow the guide, but make sure you have the USB ethernet adapter plugged in, since you might then be lucky that the setup occurs automagically in the process.

If the USB is not set up, then you need to finagle a bit with it and here it might be a bit hard to help you if it is not a brand USB adapter, but general help can be provided.

Once Debian is up and running then it just following the guide for a supervised docker installation.

You can only fail and then start over and you will learn with every new try. :slight_smile:

Thanks for the tip! Unfortunately that surface pro I was talking about…spicy pillow syndrome. So had to scratch that and I bought a thin client on eBay that I plan to flash. At least that has a built in Ethernet. So I should be up and running once that comes in. Next to figure out how Mosquito works to get into some more advanced stuff!

As long as the network card is a commonly used card, then the support and guides will be plentiful and you will be fighting Mosquittos in a very short time. :slight_smile: