Help creating automation with zwave_js_notification event type trigger


I’m trying to create an Automation to match events like this, which I see coming into Developer Logs from Z-Wave JS:

    "event_type": "zwave_js_notification",
    "data": {
        "domain": "zwave_js",
        "node_id": 3,
        "home_id": xxx,
        "device_id": "xxx",
        "command_class": 113,
        "command_class_name": "Notification",
        "label": "Light sensor",
        "type": 20,
        "event": 2,
        "event_label": "Light color transition detected",
        "parameters": {}
    "origin": "LOCAL",
    "time_fired": "2022-02-04T23:51:10.825132+00:00",
    "context": {
        "id": "xxx",
        "parent_id": null,
        "user_id": null

I tried creating an automation like this, but it never triggers, so I assume I’m missing something, but I can’t figure out what:

alias: Notify - Dryer Done
description: ''
  - platform: event
    event_type: zwave_js_notification
      domain: zwave_js
      node_id: 3
      command_class: 113
      type: 20
      event: 2
condition: []
  - service: notify.alexa_media_everywhere
      message: My text here!
        type: announce
mode: single

I’m really only concerned about the triggers, as the action runs as expected if “manually” triggered from the UI. I’m guessing it might have something to do with my event_data, but everything I’ve tried matches a subset of what’s coming in, and I’ve even tried the whole set of keys/values in case that matters (I hope not; I don’t really care what the “friendly” names are, and they might change while the node ID doesn’t). I’d also use a “real” Home Assistant entity for the trigger if I could, but I’m resorting to the event since “color change” doesn’t seem to get one of those. (Of note, the color isn’t really changing; this is a HomeSeer Flex Sensor with the “LED/light sensor” attachment and it’s really noting a blinking light on my dryer…but this is what I have to work with.)

I’d appreciate any help or pointers to resources that might help. This is the most complicated thing I’ve tried to do with Automations before (I used AppDaemon in the past for almost everything and am trying not to have to set that up again), so please also be gentle. :slight_smile:


I can’t see anything wrong with your trigger :thinking:

Hmm, thanks for checking that! I’m not sure what else could be wrong, but it always works fine if I manually run it, and I never see any indication in the UI (history, last triggered, etc.) that it is triggering, despite these events coming in in Developer Tools. :thinking:

Is the automation enabled?


You might think it’s a dumb question, but it wouldn’t be the first time that’s been the case.

I would remove domain: zwave_js from the trigger. I doubt that’s the problem (sounds like you already tried it?), but it’s redundant with the event type.

1 Like

The automation is indeed enabled, but not a bad idea to check!

Your second idea, removing domain: z_wavejs, appears to have done the trick. That actually wasn’t something I tried (I just kept adding more in case it needed an exact match or something), and I’m not sure why since that is indeed the matching domain — and probably came there from the visual editor, where I started this automation before resorting to YAML — but it looks like it’s triggering now.

Thanks, everyone!