[Help] DuckDNS domain isn't working

Hey everyone, I read all the topics in the matter but still wasn’t able to find a solution.

TLDR: I followed a few guides, but I wasn’t able to get my DuckDNS to work

Here is some information:

Currently, I can only reach my HA through https://internal_ip:8123

What I have done:

  • Created address reservation for my VM

  • Port forwarding for the address (port 8123)

  • Installed and configured DuckDNS as said in the documentation

  • Added lines to configuration.yaml

I am getting no errors on the DuckDNS log

Appreciate your help!

P.S - Sorry for not adding screenshots for every action - I can only upload 1 since I’m a new user

Here is another screenshot that might help

image

When you go to the DuckDNS website admin page does it have the correct public ip address of your router?

Have you tried accessing the DuckDNS URL (and port number) from outside your local network (turn off wifi on your mobile and try)?

Thank you for the quick reply @tom_l !

When you go to the DuckDNS website admin page does it have the correct public ip address of your router?

Yes

Have you tried accessing the DuckDNS URL (and port number) from outside your local network (turn off wifi on your mobile and try)?

I get “This site can’t be reached”

This indicates LetsEncrypt has been installed correctly.

Also good. No NAT issues.

Are you using the port number in the address, e.g. https://your-domain.duckdns.org:8123 ?

Can you share your sanitised DuckDNS addon config?

Are you running the latest version of Home Assistant (2021.7.4)?

Does your ISP block any outgoing ports?

I have also corrected the port forwarding to this:

I thought it might fix it, but unfortunately it didn’t

Are you using the port number in the address, e.g. https://your-domain.duckdns.org:8123

I have tried both with and without the port number | I have this line added to configuration.yaml external_url: https://my_domain.duckdns.org

Can you share your sanitised DuckDNS addon config?

Here it is

  accept_terms: true
  certfile: fullchain.pem
  keyfile: privkey.pem
token: Token_ID_inserted_here
domains:
  - My_Domain.duckdns.org
aliases: []
seconds: 300
type or paste code here

Are you running the latest version of Home Assistant (2021.7.4)?

I am

Does your ISP block any outgoing ports?

My internet doesn’t block any outgoing ports as far as I know

Again, Thank you for your time @tom_l :slight_smile:

You need to specify the port number when attempting to access Home Assistant as you are forwarding 8123 → 8123. If you used 443 (external) → 8123 (internal) you could leave off the port number as 443 is the default port for https.

Thanks for this, it’s helpful information.

Though, for some reason, I am still not able to reach HA through DuckDNS

@tom_l Do you happen to have another idea? I try with https://my-domain.duckdns.org

Thanks!

If you are using port forwarding 8123 → 8123 you need to specify the port when trying to access Home Assistant.

https://my-domain.duckdns.org:8123

I forwarding 443 → 8123 though,

Do you think I should change it to 8123 → 8123?

Other than that, do you think there is anything else I should try? looks to me like I’ve done everything by the book right? @tom_l

It was not clear that you had changed the port forwarding. Either should work.

Sorry it wasn’t clear enough, my bad @tom_l

Do you have any other idea why it’s still now working?

Looks like everything I try doesn’t work

Although port forwarding on your router should retain the value as it traverses to your LAN (normally it would change), you might try something called 1:1 NAT or NAT Passthrough (which might be protocol/port-specific). Some routers have specific settings for DDNS or a DMZ. Have you explored these? FYI: Before you change too many settings, you should make a backup of your router configuration.

Just open the port(s) you need, otherwise you’ll be more vulnerable to a network attack. My router will accept a comma separated list, but I avoid port forwarding if I can.

Stating the obvious, make sure the encryption is working and you have a strong password.

If you can’t get DDNS to work, there’s always Nabu Casa, which requires no open ports.

I had a similar issue and it was related to my ISP. my isp was using one public ip address but had another router after that ip address to manage different clients. Assume that 1.2.3.4 is your public address but you are not the only one assigned to this by your ISP. I am paying 3 euros per month to get a dedicated and fix ip address so i don’t need to worry about this shared pool.

Hey everyone, thank you very much for your help!

It looks like @fuatakgun is right.

Apparently my ISP is using CG-Nat, meaning I’m not the only one with my IP (I will have to switch ISPs)

Thank you @tom_l and @pocket for your help!

That’s why I asked this right back at the beginning:

If your ISP is using CGNAT the answer should have been ‘no’ not ‘yes’ as you indicated.

Then this is bad news for me because DDNS does have my correct IP and changes when my IP does.

It looks like I’ve done everything correctly.

Hey man. I have been reading your conversation regarding your question on this page. I have faced the same problem you stated and I have been trying the suggestions and still doesn’t work. Have you fixed the problem? If yes please share me your solution.
Thanks.