Help fixing a broken system

I have HA running in Docker on a Raspberry Pi and after suffering a power outage, it has not been working correctly. Specifically, my ZWave wasn’t in order. In the process of fixing that, I installed updates to the Supervisor and now it is more broken. I cannot figure out how to recover

I thought I might be able to restore from a backup, but that page just shows info about Troubleshooting. My logs page shows this

I can’t get supervisor logs - it says Bad Gateway. I don’t know where I would start to fix this!

I tried creating a new docker container using:

sudo docker run -d --name homeassistant --restart=unless-stopped --privileged -e TZ=America/New_York -v /home/homeassistant:/config --network=host

I had to stop and rename the original container, and this new one runs fine. I can revert to the old container and all my configuration is there, but I don’t know where I might find it on my file system. I thought it would be under /home/homeassistant, but that just appears to be the data from the new container, even though the old container still shows its data.

Can anyone offer any advice on how to proceed? If I could just get hold of the old data and apply it to the new container, that would be sufficient.

Thanks in advance

In the old system, where was config pointed to

It used the same /home/homeassistant

When I start up the old system, all of the configuration is still there, I just don’t know how to back it up and transfer it the new docker instance. I don’t know physically where it is stored.

I am going to close this, not because I fixed it, but because I recovered in a different manner.

I restored my entire system to a previous full system backup. I then disconnected my network from the internet and restarted HA. At the CLI I ran ha supervisor options --auto-update=false to stop the supervisor from updating itself. I then reconnected to the internet.

Following a workaround in the thread at Supervisor failed to set up after trying to update Core to 2023.9 · Issue #4531 · home-assistant/supervisor · GitHub, I manually set DNS to in HA, and then manually updated supervisor. This time the update worked. Hopefully I’ll be able to continue as before …

You said /home/homeassistant