Help for flashing Sonoff Touch

Hi, I’m italian, I need a tutorial for flashing a Sonoff Touch wall switch with a firmware MQTT compatible to use with HA.
I saw many info about but some of them use ESPEasy, some Tasmota and other firmwares.
I’m a newbie, I need the simplest solution… and a tutorial step by step to do it.

This is my Sonoff board with ESP8285

it seem different from other board image it is a PSF-A chip
My board is similar to the board and chip in this guide but not identical: and

but…where is the GPIO_0?

I linked the board to my FTDI FT232RL

I have to link it to the GND of the FTDI 232RL?

Many peolple says Tasmota is more simple to use.
Please give me a step by step tutorial to flash Tasmota firmware

Read through the Tasmota wiki, which you seem to have already found, and it will give you what you’re after, tutorials, link to vids, differences between devices and the necessary set up differences.

Platformio is the simplest method as recommended on that site.

You can also use Espurna. Firmware can be flashed via PlatformIO or Arduino IDE.

sorry… I’m unable to find wich is the GPIO_0 on the new PSF-A chip… I have to link it to GND of FTDI
PSF-A chip of new Sonoff Touch has different design

Board layout seems the same as the left hand image in the wiki and it does say the position of gpio0 is the same whichever chip you have so that’s what I’d go for.

OK, I uploaded the firmware…

Enviroment sonoff [SUCCESS]

after I restart switch board
Then I go to Serial monitor… choosed USB serial port COM8 … and 115000 baud …clic START
but it write a infinite string of special characters :frowning:

What I did wrong???

Try different baud rates starting with 9600. That will solve the problem

problem not solved :frowning:
at 300 baud problem persist

I meant from 9600 up…

check this video

At 74880 give me this message:

fatal exc2ption (28):
epc1=0x040001800 epc2=0x00000000, epc3=0x00000000, excvaddr=0x00007ff0, dpc=0x00000000

Which firmware did you flash? Tasmota or Espurna?

Make sure you flash it with a good quality cable. Many of the errors when flashing are caused by cheap cables…

I’m installing Tasmota, but during flashing operation it showed me Enviroment sonoff [SUCCESS]
and now why it is unable to connect to it?

Try flashing again. Make sure flashing speed is 115200 or slower, but not too slow.

Read this about error 28:

Have you tried just powering it up and going to it’s web interface? The important bit is the success message and you got that. I flashed 10 Basics at the weekend and didn’t bother with the serial monitor bit, didn’t see the point.

How may I know its IP address?
I found in my network a device name Espressif at
At wich port it answer?

Just enter the IP address on the browser. I think it defaults to port 80.

You don’t need a port number, just stick the IP in a web browser and away you go :+1:

It wasn’t it but another device I have in my network with ESP chip