Help getting started - did I get the wrong installation?

I have installed HA on my Qnap using the container available in the container station for Qnap.

I assumed I was done with the first page of the getting started so I went to the second page, and I got stuck.

  1. The first problem was how to access HA. After some googling I tried to go the IP address of the Qnap with the port 8123 and it worked. But nowhere in the getting started talks about it.

  2. Then the getting started talks about creating the owner account, but it doesn’t say how. When I went to the HA page it was already logged, without asking for user name or password. If I log out a screen asking for password appears. There is no user name field and I can login without entering any password.

  3. After a few minutes an icon saying “Update Available” appeared, I clicked on it, then I clicked on the “Update Instructions” link, but I got a 404 error.

  4. I tried to explore all the options in the UI, but I can’t find any user profile or configuration or administration section.

At this point I am wondering if I have installed something different from what the getting started talks about.
I’m surprised that there is no mention about how to access it, no mention about how to create a new user, the link about the update is not working.

Any idea why I am having such an hard time doing something that was supposed to be very simple?

@samnewman86 Thanks for the answer, but your snapshot addresses the only point for which I already had an answer (as I mentioned in the original post).

Your snapshot is from the Bluetooth section. I am not interested on the Bluethoot. Do I still need to go through those steps?

What about the creation of the user account?

What about the missing onboarding?

What about the 404 on the link for the update?

On the Qnap section says:

Remark: To update your Home Assistant on your Docker within Qnap NAS, you just remove container and image and do steps again (Don’t remove “config” folder).

I created the container one hour ago, does that mean that if I create another one now it will be with another version?

I have already spent a few hours, deleted and recreated the container a few times, but I keep getting stuck at the onboarding. There is no request for user creation and I don’t understand how to upgrade to the new version.

@samnewman86 I’m afraid that my post will get no traffic because you already gave an answer. Can you please try to address my other points? Or should I create another post?

No it’s from the end of the installation section. Before onboarding. You said this bit was missing from the instructions.
Have you ever installed in the past? Could it be picking up an old config?

No, the Qnap is a few years old, I’ve been using it as Plex server, but I just installed the Container station and Home Assistant for the first time.

The last time I deleted the container was about 45 minutes ago. Right now I don’t have the link for the update. I think it will reappear soon.

The getting started page recommends upgrading to Home Assistant Core 2021.1.5, but my installation has the 0.65.5. How is it possible that the versioning uses different naming standards?

Wow that is years old.
A few months ago it switched to a monthly release cycle and adopted the date formatted versioning scheme.
Current is 2021.2.3

Can you download the latest version from here and install it in virtualization station on your qnap?
Seems and .ova file should work

Thanks for confirming that I was using an old version.

I found this article and I’m trying with the non Qnap official installation right now.

How did you get on?

I created the container and it was working immediately.

I started configuring and exploring, then I forgot the password and I was locked out.

This proof of my stupidity came after just a few minutes, so I deleted the container rather than getting crazy with whatever it takes to get back in, and went to bed.

I will work on it tonight, but I think that using the software that matches the documentation will be easier than using an ancient museum wreck that doesn’t even look or behave like documentation says it should.

Definitely, is important to be up to date👍
There’s been some security patches in the last few months too

It wasn’t matter of security patches.

There was no onboarding, the UI was showing one tenth of the options, it was a completely different application.

I reported an issue for the documentation, I think they will remove the part that suggests to use the official Qnap container.