Help! I moved from supervised to HAOS, restored my backup, and HA is still borked! Add-on problems on 2022.11

Hello Community, I’ve run the supervised version of home assistant for a couple of years now and it’s been really solid. I recently tried to update to 2022.11 and noticed the Journal/Systemd “unsupported installation” message.

I read through some of the similar posts on the community and found someone recommending to reinstall the supervisor ‘deb’ file. I was working through that when I neglected to remember that I originally installed my supervised version of home assistant to a custom location with the -d option on the old script (which is no longer available).

Well, doing that completely screwed up the system. Now, HA cannot see any Add-ons as running, even though they are actually running. I have ESPHome, Studio Code Server, Unifi Network Application, JupyterLab, etc. HA shows them all as greyed out, and they all have the red dot like their stopped. I can hit the ‘start’ button but nothing happens. When I try to use ESPHome or Studio Code Server ingress, it says I need to start the add-on. When I try to navigate to the URL to use Unifi Network Application it’s actually up.

I went into the discord to try to get help and the guys in there told me that “I should not bother trying to figure out the supervisor problem, that I should be running the HAOS”. So, tonight, I took the plunge and moved the system to HAOS and restored my backup (which was from before I updated the system to 2022.11, while it was working great) and lo and behold, the Add-ons are still broken! :angry:

How can I fix this so that I can use my add-ons again? Now the system is even more difficult to deal with since I can’t actually ssh into it and I can’t pull up the config files! What’s the solution?? PLEASE HELP!

“the addons are broken” is not very descriptive. Can you clarify what about them is not working? Does that mean they won’t start? If so where do you see an error? Do you see an error in the log of the addon when you press start (this suggests some kind of config issue) or in supervisors log or in a pop up box (this suggests a problem getting the image)? Can you share any errors you see?

EDIT: Also if you haven’t tried it yet, try uninstalling and reinstalling some of the stateless ones. Like the ones for ssh, samba, Mqtt, etc. Obviously for some like Mariadb or influx (if you use those) you really want to keep your backup since there’s a lot of data in there. But for many of them (like the ones I listed) there’s really nothing in the backup other then what’s on the config tab which can be copied and pasted after a reinstall

Home Assistant shows all of them as greyed out from the “Add-ons” page. Clicking on one of them shows that it’s not running:

  • the “red dot” is displayed
  • there is no “stop” button, only a “start” button
  • clicking on any ingress link yield HA to state “Add-on is not running. Please start it first” and it takes me to the its Add-on page.

clicking the start button does nothing to change the appearance, no error is presented. Looking at the “logs” tab shows that services are up and running. Hitting the URL for external services works great!! :frowning:

Unfortunately, there are no errors. The best that I’ve seen is looking in the supervisor logs I see a lot of this:

22-11-04 17:54:20 WARNING (MainThread) [supervisor.addons.addon] core_zwave_js is already running!
22-11-04 17:55:40 WARNING (MainThread) [supervisor.addons.addon] core_zwave_js is already running!
22-11-04 17:57:00 WARNING (MainThread) [supervisor.addons.addon] core_zwave_js is already running!

Which is another Add-on that I have that Home Assistant shows isn’t started.

I just tried installing a new Add-on to see if I could see a different result. I installed Glances and it does exactly like the others. Home Assistant always shows the red dot but after pressing start, the Log tab shows it started and is running.

I tried installing a new one (Glances) so it wouldn’t get any of the old, possibly problematic, configuration stuff and the problem persists on that Add-on, as well.

Oh. That sounds like a bug. Actually one I thought I fixed with this

I guess I’ll look into it again, see if I missed something.

Regardless it sounds like your addons are running but the frontend isn’t showing it correctly. In that case do you have the ssh addon installed? If so you should be able to ssh in as HA may not know it’s running but it is. If not then install it. Once you’re in just execute this command:

ha supervisor restart

Alternatively a host reboot should fix it as well. You can do that from the UI by Settings → System → Hardware then do reboot from the menu in the top right.

YES! You got me fixed up, I tried the ha supervisor restart first and it worked to get the Add-ons back. Then I tried the system reboot and SUCCESS! I thought I had tried that before but I guess I had not.

Thank you so much Mike!

1 Like