Help Need: Integrate icatch dvr into Home Assistant, Headers in FFMpeg Camera Platform

Hello everybody.
i’m trying to integrate an icatch dvr and since i couldn’t find any other topic open about it, i decided to create a new one.
my goal is to integrate the dvr with a high quality stream and not just the low quality one.
I initially tried to use others integrations already present in Home Assistant (onvif, generic cam etc.) or in HACS, but this didn’t lead me to get anything.
So I started sniffing my network traffic with Wireshark while connecting the application to the dvr, and boom! I found something:

following the TCP stream i found how much a high quality path:
The problem is that when i enter the modified url, i can’t extract any image or frame, just a permanent download status:

going back to wireshark, I think that the problem is in my request because i don’t specify the “Magic: code” (I searched everywhere, but I didn’t find anything mentioning this strange magic code, you can find it in the first photo, under Authorization).
Do you think through ffmpeg I can somehow add “Magic: Code” as header in order to be accepted? Maybe for a security reason the dvr requires this parameter as header? Also does anyone know how I can test this?
I’ve been behind this mini project for months… if anyone would like to help me I would be grateful.

i’ve added this at my confiuration.yaml but it doesn’t work.

  - platform: ffmpeg
      - -headers
      - "Authorization: Basic ..........."
      - "Magic: ..............."

how can i add more inputs argoments?

I’ve tried so many different ways to make it work but nothing… does anyone know how i can add the headers to the request? this is what i’ve tried:

  - platform: ffmpeg
    name: prova1 
    extra_arguments: "-headers Authorization: Basic ***********, -headers Magic: ***********"
  - platform: ffmpeg
    name: prova2
    extra_arguments: "-headers Authorization: Basic *********** Magic: ***********"
  - platform: ffmpeg
    name: prova3
    extra_arguments: "-headers Authorization: Basic *********** -headers Magic: ***********"
  - platform: ffmpeg
    name: prova4
    extra_arguments: "-headers Authorization: Basic ***********; -headers Magic: ***********"