Help needed setting up Conbee II via Virtualbox

Hi all!

I am trying to setup Conbee II via Virtualbox.

This is the setup:

OS: Ubuntu 18.04.5. Running HomeAssistant in Virtualbox. I managed to configure the Conbee II as a serial port and Virtualbox gave no errors while booting up HomeAssistant. I tried configuring it as a USB device but it was not showing up in the list; that’s why I configured it as a serial port.

Nevertheless, I tried connecting to it via deCONZ in Supervisor, but no matter what device I configure, it is simply not visible in the Phoscon app. I tried /dev/ttyS0, /dev/ttyS1, /dev/ttyS2, /dev/ttyS3, /dev/ttyACM0, /dev/ttyACM1. It just does not show up.

Does anybody have any advice on making it work?

The Conbee II works fine if I use it directly in Ubuntu but there is another issue that the devices are listed as unavailable in HomeAssistant, even though they are all visible.

Any tips are welcome!

Thank you in advance!

I did not find a viable solution. I think it might have been a communication/permissions issue that I missed or configured improperly.

Therefore I gave up. The solution that I implement is an old Raspberry PI 2 that I dedicated exclusively to the Conbee II platform.

Now everything works great!