Help needed to update zwavejs2MQTT to version 7.2

I need to some help.
I am trying to update ZWavejs2MQTT from version 6.8 to 7.2. As I have understood that I need min version 7 to run Home Assistant 2022.9, presently on 2002.8

I have setup the zwavejs2mqtt on a raspberry pi using docker, using the steps outline is this article from Flemming. I am not very familiar using docker, so…

Then I have tried to update to version 7.2 using the steps outlined here

Except using the command
sudo docker pull zwavejs/zwavejs2mqtt:7.2.0

I do get the message when running the compose command
recreating zwavejs2mqtt

But when I start the program, it is still on 6.8.

When I run the commands one more time it tells me that 7.2 is downloaded.

So what am I doing wrong, can anybody help me?

The Raspberry PI is a model 4 with 4GB ram.


You need to edit your docker compose file to use the updated image tag, 7.2.0. If your compose image is set to latest, you need to pull that one, but latest will not be 7.2.0.

FYI, the project name and images have changed, and the latest version of Z-Wave JS UI (formerly mqtt) is 8.4.1.

Are you using the Z-Wave integration, or just MQTT? If you followed this guide completely, it would mean you aren’t using the Z-Wave integration, you are using MQTT. In that case, there is no minimum required version. The version requirements are specific to using the Z-Wave integration (websocket server).

Thank you, changing the compose file did the trick. I am working my way up to the latest version on this software, but take it step by step. And yes, I am using only the MQTT part of it.

Then you aren’t required to upgrade. You may want to for other reasons, such as if there are any MQTT related bug fixes, but there are no HA requirements to use new versions.